Windows Expert Chat - Strike 2

Site blocks Safari 3.1 even though it states i should use Safari 1.2 or higher. Blocked me from the IE8 Windows XP Expert Zone Chat.

559 views
0 faves
0 comments
Uploaded on March 20, 2008
This photo is in 1 album

Additional info

  • Viewing this photo Public
  • Safety level of this photo Safe
  • S Search
    Photo navigation
    < > Thumbnail navigation
    Z Zoom
    B Back to context