Help / The Help Forum

This thread was closed automatically due to a lack of responses over the last month.

Hot Topics

[Official Thread] Show off your photos in pixel-perfect glory with new 6K support for Pros
Latest: 2 hours ago
Updates to the Flickr Android App
Latest: 2 days ago
[Official Thread] An update on Flickr search
Latest: 2 days ago
[Official Thread] Print your photos with Flickr Prints
Latest: 3 days ago
[Official Thread] Flickr downtime on May 22 and site issues since then. [10 SEP UPDATE - MOBILE Camera Roll Is Back!]
Latest: 6 days ago
[Official Thread] Flickr login freedom is here
Latest: 6 days ago

 

Current Discussion

Unexplained surge in total views
Latest: 12 minutes ago
Harassments
Latest: 23 minutes ago
ladda ned min gamla bilder
Latest: 53 minutes ago
Download Blocked
Latest: 80 minutes ago
Flickr Explore limited to a small number of photos?
Latest: 2 hours ago
Is Stats still inaccurate?
Latest: 2 hours ago
Albums out of order
Latest: 3 hours ago
Disappointed with Flickr since SmugMug
Latest: 4 hours ago
A mysterious place with no name
Latest: 5 hours ago
Cover images for albums not displaying
Latest: 5 hours ago
Photo Blur
Latest: 12 hours ago
(Resolved: not a bug) Group invite tool doesn't check for existing membership
Latest: 14 hours ago
More...

Search the Help Forum

Album embed code not rotating images

benviall says:

I'm trying to embed an album on a webpage, and for one account the embed code works, i.e. there are arrows you can use to progress through images, and on the other the embed code it only shows a single image.

The working code below is from my account, and the non working code is from my customers account - where they have used the same steps to source the embed code.

WORKING:

Test

NOT WORKING:
Professional Development Series I

Can someone please advise on how to get the correct embed code in order to display an embedded gallery.

Thanks, Ben
Posted at 4:56PM, 26 February 2017 PDT ( permalink )

view photos

benviall says:

Their code (not working):
Professional Development Series I

My code (working):
Test
Posted 32 months ago. ( permalink )

view photos

benviall says:

How do you post code without it showing here?
Posted 32 months ago. ( permalink )

view photos

kmacgray says:

benviall:

You need to escape all of the HTML first in order for it to display as raw code here. I use this tool:

www.htmlescape.net/htmlescape_tool.html

there are arrows you can use to progress through images

I currently don't see arrows on any of the examples above.
Posted 32 months ago. ( permalink )

view photos

MabelAmber️®***Pluto5339*** incognito says:

I t kmacgray:

I currently don't see arrows on any of the examples above

I think OP means the left/right arrows on the embedded Album on the external site.
Posted 32 months ago. ( permalink )

view photos

kmacgray says:

Oh. Well, without that key piece of obvious information (a link to the site in question), we can only guess.
Posted 32 months ago. ( permalink )

view photos

The Searcher says:

benviall: It's possible that the embed code requires Flash to display with interactive elements. So people who do not have Flash installed on their computers will not see the interactive version.

It could be that Flickr upgraded to HTML5 since I last checked. In that case it will display for more people, but older browsers still may not be able to show the interactive elements.
Posted 32 months ago. ( permalink )

view photos

MabelAmber️®***Pluto5339*** incognito says:

benviall:

The "working" code is for an Album with public images, the non working is for one containing private content.
Posted 32 months ago. ( permalink )

view photos

studyabroadwmu says:

I had this problem too and I noticed the embed code was different between my albums that worked and the ones that didn't.

Here is your embed code for your album which is working:

<a data-flickr-embed="true" href="https://www.flickr.com/photos/147027681@N05/albums/72157677722141155" title="Test"><img src="https://c1.staticflickr.com/1/305/31544870156_e251c110b3_k.jpg" width="2048" height="1280" alt="Test"></a><script async src="//embedr.flickr.com/assets/client-code.js" charset="utf-8"></script>

I can't see the embed code for the album that is not working but if you have the same problem I did, the code probably looks different with the hyperlink being a different format and the alt, height, and width tags being in different spots. For example, the hyperlink in the embed code for the album that doesn't work probably looks something like this:

href="https://www.flickr.com/gp/142330153@N08/1osY9z"

All I did to fix the embedded albums that wouldn't rotate through images was to format the hyperlink the same way the working albums had it.

So in your hyperlink, change "gp" to "photos" and replace "1osY9z" with "albums/*album number*". You can find the album number by just going to the album and getting the number at the end of the URL, in your case: 72157675279004373. So assuming I did everything right, your correct hyperlink should look like:

href="https://www.flickr.com/photos/142330153@N08/albums/72157675279004373"

The album doesn't have any sharing options so I can't check it. Replace the hyperlink and try it out, I think it should work for you. I didn't change anything else and that fixed it for me.
Posted 32 months ago. ( permalink )

view photos

benviall says:

benviall:

WORKING (resoundconnect.com/blogs/past-events/test-gallery)

<a data-flickr-embed="true" href="https://www.flickr.com/photos/147011262@N06/albums/72157677733258001" title="TEST ALBUM"><img src="https://c1.staticflickr.com/1/294/32350022161_c30651ce24_z.jpg" width="640" height="480" alt="TEST ALBUM"></a><script async src="//embedr.flickr.com/assets/client-code.js" charset="utf-8"></script>

NOT WORKING (resoundconnect.com/blogs/past-events/test-gallery-jb)

<a data-flickr-embed="true" href="https://www.flickr.com/gp/142330153@N08/LGwG78" title="ASA World Congress 2014"><img src="https://c1.staticflickr.com/1/324/32072851062_9f2d163d75_z.jpg" width="640" height="480" alt="ASA World Congress 2014"></a><script async src="//embedr.flickr.com/assets/client-code.js" charset="utf-8"></script>
Posted 32 months ago. ( permalink )

view photos

MabelAmber️®***Pluto5339*** incognito says:

benviall:

As I mentioned before, the one *not* working contains private content, I see the "gp" in the url, which denotes the code is for a Guest Pass.

So that could be the reason the left/right arrows are absent on that Album as on your blog.
Posted 32 months ago. ( permalink )

This thread was closed automatically due to a lack of responses over the last month.

Subscribe to a feed of stuff on this page... Feed – Subscribe to help discussion threads