Discussions (1361)

For WordPress 2.2 users...

view profile

Joe Tan is a group administrator Joe Tan says:

Until the next release, here is a quick fix to resolve the 404 issue on your write / edit screens if you have upgraded to WordPress 2.2.

On line 208 of the file "class-admin.php" in the directory "silaspartners/flickr/"

change this line:

if (!ereg('^2.1', get_bloginfo('version'))) {

to this:

if (version_compare(get_bloginfo('version'), '2.1', '<')) {

or, you can just download the updated file directly from SVN:

photo-album.googlecode.com/svn/trunk/silaspartners/flickr...
7:41AM, 16 May 2007 PDT (permalink)

eager glove [deleted] says:

Awsome! That did the trick, except I had to change the 2.1 in that new line to 2.2. Before I did that the uploads area wouldn't load at all, it just sort of hung there trying to load it up after the rest of the page had loaded. I hope I didn't break something elsewhere by changing it. ^_^
ages ago (permalink)

view photostream

ourladyofwisdom says:

THANKS!! that fixed the problem.
ages ago (permalink)

view photostream

muzicman82 says:

Hmm.. I haven't tried this, but I managed to fix it with this:

www.flickr.com/groups/tantannoodles/discuss/7215760023213...
ages ago (permalink)

view photostream

antonpiatek says:

Thanks for this, it is a shame this was not put on the wiki for the project (on google code).
ages ago (permalink)

absorbed pear [deleted] says:

Thanks! That saved me lot of anguish as why my upload photos vanished after I upgraded to WP 2.2
ages ago (permalink)

modern wool [deleted] says:

Thanks alot, all fixed now :)
ages ago (permalink)

view photostream

guido_cc says:

Muchas gracias, al fin se solucionò este problema. muchas gracias :D
ages ago (permalink)

absorbed pear [deleted] says:

I use WP 2.2 and am getting this error:

Warning: array_pop() [function.array-pop]: The argument should be an array in ../wp-content/plugins/silaspartners/flickr/admin-photos-tab.html on line 103.

The inserting of photo works fine though but still this error looks ugly and hope it isn't messing anything else up. Any idea?
ages ago (permalink)

view photostream

evilsciencechick says:

PatrixBlogs - I am getting the same error, with the same non-effect but-looks-ugly. Anyone know how to fix it?
ages ago (permalink)

view photostream

finch31 says:

I am using the previous version .89 which does not have this file, what is the file that was used in that version (class-admin). Not worth upgrading to .91 if a new version is imminent to replace .91....
ages ago (permalink)

marvelous cable [deleted] says:

Thank you! My photo uploader had disappeared and I was getting worried. This did the trick!
ages ago (permalink)

view photostream

BlindWolf8 says:

Awesome! Great fix! Any ETA on the next version? It's been a long while.
ages ago (permalink)

view photostream

Nordin Rahhali says:

Word

Thanks for finding that one, I'm glad I checked this thread! :)

Great Plugin BTW.
ages ago (permalink)

view photostream

indietravel says:

Working for me too...I'm just switching from the defunct fgallery plugin, so lots of archive work to do :(

Thanks for the plugin Joe.
ages ago (permalink)

view photostream

ivfaq says:

Hi!

I have the version 0.89 of the Plugin installed and there is no file called class-admin.php.
I can't reach the Website to download a newer version and therefore I ether have to deactivate the Plugin or I have no Upload on my Postpage. Is there an other site with the actual Plugin to download or can somebody mail me the Plugin to jwagner@dressler.biz ?
Thank you!

Juergen
ages ago (permalink)

Would you like to comment?

Sign up for a free account, or sign in (if you're already a member).