☣ cUKi 1:57am, 27 January 2010
Executive summary: My Yongnuo 465 goes totally nuts when installed in the hotshoe of my Canon Powershot Pro1, and it works fine with my Canon 450D. I don't understand why and I wish I did, so I can fix this.

-----------------------------------------

Please forgive me for the totally off-topic thread - I chose to post the question in here rather than some obscure group just because in here are lots of folks that I trust they know their stuff.

So, I've got this Canon Pro1 on Ebay, it's a neat compact with a hotshoe and an L lens and cheaper than a G5. Like my 450D, it's supposed to speak E-TTL. I've also got on Ebay this YN465 which is also supposed to speak E-TTL. And I've got this E-TTL cable, well, from Ebay.

My memory is failing on me already. I'm not sure if I tried the flash on the Pro1's hot shoe as soon as I got it, the thing is I think I did and the camera controlled the flash well (kinda' remember playing with the idiot lights from the camera's cursors). I put the gear away for a short while, and after that I realised that the flash doesn't work well at all with the Pro1, while it works fine with the 450D. On the Pro1, the flash can't be consistently controlled from the camera neither in Manual nor in Av, the wheel on the flash won't switch the unit from TTL to Manual or control it's power level, even the idiot lights won't work properly (they will change only after taking a shot or two). The only way to use that flash with that camera is à la Strobist, in Manual mode via a radio trigger. Which might be good enough for most people, but I kinda' wanted to also have E-TTL in the bag.

I've Googled a lot, I rubbed the hotshoe contacts with some microfibre cloth and contact spray, nothing changed. If I put the flash on the cable, the same. With the locking pin on and off, the same. Tried to move the flash in the hot shoe, it doesn't move. Meanwhile, the flash is working fine with and without the cable on the 450D, and the on-camera flash is fully controllable on the Pro1.

Here goes my question: is the YN465 compatible with the Pro1? Are they speaking the same E-TTL (I think the Pro1 was released before E-TTL2)? Can you try and confirm with actual gear? Or, is my Pro1 defective (all the sudden, I wasn't happy with my new toy anymore), or my YN465?

Thanks!
rebel memory [deleted] Posted 9 years ago. Edited by rebel memory (member) 9 years ago
forums.dpreview.com/forums/read.asp?forum=1010&messag...

Quote:
Right, but not in Manual mode. I have a 550 EX and there is no flash autoexposure in Manual. It defaults to full output (1:1) if your flash is in ETTL mode and the Pro1 is in Manual. Why Canon does this on their digicams but not their SLRs is a mystery to me.

PhillipsArt wrote:

Hi Tommy from what I understand You will require one of Canon's EX
flash, to use ETTL on a external flash.

Phillip.

Tommy Huynh wrote:

Is there a hack to get flash autoexposure (whether ETTL or TTL) to
become active with the Pro1 when you attach an external flash?

--
www.lumika.org


edit1: My guess is that the non-Canon flashes don't read the full AIM data--
When in E-TTL operation, flash exposure is measured and controlled by the camera in combination with Canon's AIM system. Subject position, ambient light level, evaluative metering and pre-flash data are instantly analyzed, including heavy backlighting or reflections from background windows or mirrors.
☣ cUKi Posted 9 years ago. Edited by ☣ cUKi (member) 9 years ago
With the camera on Manual, the FEC slider on the camera turns into a Power Level slider (from1/16 to 1/1 in 1/3 increments), the flash unit should switch by itself to Manual, and the idiot lights should reflect the power setting selected on the camera (I think it worked like this at first, not really sure).

It certainly doesn't do it anymore, and something definitely goes very wrong. When the flash is on camera it can't be controlled even from it's own wheel - turning it from OFF to TTL or Manual doens't make the LEDs go on or the flash to power up. At the first shot taken the TTL LED goes on, then after another shot the Idiot Lights show some Manual power level but the flash is still uncontrollable and on full power. On Av with TTL, the flash always fires at full power).
☣ cUKi 9 years ago
Anyone, please?
☣ cUKi 9 years ago
Well...
MOD
It's just Mark PRO 9 years ago
I got nuthin'
Sorry. I want to help, but this gear is not what I use.
brownie114 9 years ago
Have you tried it with a true Canon flash unit?
☣ cUKi Posted 9 years ago. Edited by ☣ cUKi (member) 9 years ago
Well, I did, sort of - I went to a local camera shop and I asked them to let me try a Canon flash. They seemed so busy and annoyed by my request that I didn't allow myself enough time to be really sure about the test's results. They gave me a small new flash - I don't remember the model, but it was a compact unit, not a cobra-type one. Anyway, the shots I've taken didn't seem well exposed, and the manual settings didn't seem to work either. This kinda' points to the camera or its hot shoe, but I can't tell for sure. Newer Canon flashes are supposed to work with both E-TTL and E-TTL 2, I guess, and I know for a fact that the Pro1 camera was released before E-TTL2. Could this be a compatibility problem, a dirty hot shoe (hard to believe after all the rubbing), or a broken camera? The confusing thing is that it works as supposed with the pop-up flash... I feel the answer is a stupidly simple one still I fail to see it.

EDIT: I've bought the camera on Ebay, I was glad it was way cheaper than most G-series cameras (120 or so GBP), I can't afford to send it to Canon for diagnostics and repairs. If it's broken, there's a good chance it's gonna stay broken. It triggers my radios, so it's still useable for strobist shooting, but I can't use it with the E-TTL cable for quick candids - and that's what I was thinking to use it for.
brownie114 9 years ago
Reading Canon's flash specifications I found that the only current flash that specifically mentions Pro 1 compatibility is the 580exII.
☣ cUKi Posted 9 years ago. Edited by ☣ cUKi (member) 9 years ago
brownie114: I'm wondering why. Anyway, thanks for looking into it.
☣ cUKi 8 years ago
Please allow me just one more bump.
☣ cUKi Posted 8 years ago. Edited by ☣ cUKi (member) 8 years ago
Maybe since the original post someone has got both a PowerShot Pro1 and a YN-465? I still haven't got a clue whether my Pro1 is broken or my 465 is not compatible with it. The reason I'm asking again is because I'm thinking of buying on Ebay another E-TTL (2) flash, maybe a Nissin, to use with this camera - will it work or not?

Note: For the curious, I've just found a page describing an attempt at reverse-engineering the E-TTL protocol:

kzar.net/wiki/Photo/CanonE-TTLProtocol

I'm trying to make sense of it, meanwhile could you recommend a way of testing my camera's hot shoe pins with a logic probe or a multimeter?
Groups Beta