youdliehoodlie 2:26pm, 5 November 2011
I guess I trashed some files that are important to Lightzone. Every time I try to open the app, I get the message: esellerate software not installed. Does anyone have any idea how and where I can get the necessary esellerate software to make Lightzone work again? Thanks
Doug Pardee 7 years ago
You'll need to re-install. Which version are you using: Windows, Mac, or Linux?
youdliehoodlie 7 years ago
I'm using a Mac. Do you mean reinstall from a .dmg file? I have done that and I get the message that the esellerate software is not installed. Do you have another method of installing Lightzone? Thanks
Doug Pardee 7 years ago
It should be installed from the DMG file. In the Java folder, there should be a file called eSellerateActivate and a file called libESD.jnilib.

What version of LightZone did you install? The latest/last version for Mac is 3.9.2. And which version of Mac OS X are you running? Snow Leopard? Lion?
youdliehoodlie 7 years ago
Thanks for your help, Doug. I am running Lion 10.7.2. I have the dmg file for LightZone 3.9.2. I am not finding either of the files you mentioned in Macintosh>Library>Java, nor in Macintosh>System>Library>Java.

I have opened the LightZone package contents and found eSellerateActivate and libESD.jnilib, and dragged them to Macintosh>Library>Java. The problem persists: I get the same message - eSellerate software not installed.

Do those files go directly into the Macintosh>Library>Java folder, or inside yet another folder? Or perhaps I have put them in the wrong Java folder.

It is curious that those files are not found in my TimeMachine backups.
Doug Pardee 7 years ago
It should be in the LightZone app. I'm not familiar with how things get installed on Mac OS X, but in the DMG file it's under LightZone.app/Contents/Resources/Java

It's possible that the eSellerate software in the 3.9.2 version isn't compatible with later versions of Lion. I'm researching that.
youdliehoodlie 7 years ago
I see what you mean - on installation, the files don't get written to library folders - they stay in the app package. As a point of curiosity, I tried installing LZ 3.9.2 on a machine running OS X 10.5.x and it ran perfectly. There was a message that it was updating the eSellerate software, so I compared the Java folder from the dmg to the Java folder from the app package after the update and they appeared to be identical. It would seem your suspicion is correct that the eSellerate software may not be compatible with OS X 10.7.2.
Doug Pardee 7 years ago
One of the members on LightZombie reports this relative to Mac Pro and MacBook:

Both have Mac OS X Lion installed, now at version 10.7.2 and with recent Apple software updates both have Java updated to version 1.6.0.jdk early this month.

The files in question i.e. eSellerateActivate and libESD.jnilib are accessed as follows:

Go to Applications/Lightzone.app - right click on the app and click on Show Package Contents - click on Contents - click on Resources - click on Java - listed there are the two files among others.

eSellerateActivate is 101 kb, described as Unix Executable file, dated 8 July 2011 15.06

libESD.jnilib is 138 kb, described as Document, dated 8 July 2011 15.06
Doug Pardee Posted 7 years ago. Edited by Doug Pardee (member) 7 years ago
More information from that LightZombie member:

eSellerate has its own folder to be found as follows:

Go to Users folder on the system hard drive, then go to the "Home" folder, then Library, then Application Support, there find the eSellerate folder. Within is a folder with a name made up of 9 digits which may relate to the activation code.

Within that folder is EWSMac.framework folder, which itself contains other folders and a pointer to an EWSMacxxxxxxxx Unix Executable file. The other folders carry on to show further files and folders. The xxxxxxxx is an 8 digit number.

It should be noted that Mac OS X Lion hides the Library folder in the "Home" folder as default. It has to be "unhidden". For those not worried to use Terminal: Open Terminal and type chflags nohidden /Users/[username]/Library/ and press Return. That makes its visibility permanent.

Otherwise in FINDER, on the top menu line click on GO while holding down the OPTION key or in FINDER, GO > Go to Folder command, then type ~/Library. These commands are not permanent.

Visiting the LightZombie forums might be your best bet on getting help with this problem.
oceanic property [deleted] 7 years ago
i am glad i found this forum -- i am able to follow most of the threads, however a few times i get lost with some of the technical information.

i am very interested in working with lightzone again. i was an program that i worked w/ often. can i still use it somehow.

i am getting a message every time i try to open it that says "there is an internal error". i am running the program on a mac system 10.6.8.

i would appreciate any help in getting the program up and running.
Groups Beta