admin
Ronounours 9:05pm, 4 November 2011
New features :

- New substituting expression '{`value1,...,valueN`}' : it is substituted by the string whose ascii codes are the given values (that the opposite substitution to '{'string'}').
- New substituting expression '$*' in custom commands : it is substituted by a verbatim copy of the specified arguments string. This is now used in some commands so, it breaks the compatibility with previous versions of G'MIC. Version 1.5.0.6 won't be updated anymore then !
- New command '-x_fireworks' that launches a simple fireworks animated demo (requires the command line version 'gmic' of G'MIC). Looks like this :



- New command '-x_whirl' that launches a kind of Fractal whirl animated demo (requires the command line version 'gmic' of G'MIC). Looks like this :



- New global command '-version' (or '--version') for the command line tool 'gmic'. It displays the current version number of the binary.

Improvements :

- On Windows, the configuration files (.gmic_faves, .gmic_sources, .gmic_def.xxx and all external sources) have now filenames *without* the first dot. Windows does not like filenames starting with a dot, and it is sometimes difficult to copy/paste/remove those files. Now, this should be easier.
- The G'MIC plug-in now contains its own random number generator to avoid issues with the generation of random numbers (seems that GIMP is calling std::srand() periodically, with the same seed each time, leading to not so random sequences at the end).
- Command '-plasma' has been recoded from scratch, it is now significantly faster and does not render images with artefacts along x and y directions. It uses the so-called 'Diamond-square' algorithm instead of the square-only 'Midpoint displacement' algorithm as used before. There is a comparison of the old (left) and new (right) rendering below :


- Reference documentation have been updated : there are slightly more precisions on the language rules and commands have been rearranged in more coherent sections, and alphabetically sorted within sections. Generation of command samples has been also improved.
- Added support of the clang++/LLVM compiler, fixing some warnings in the G'MIC source code.
- Command '-lightrays' has been slightly optimized.
- Shared library file 'libgmic.so' on Linux is now correctly versioned.

Bug corrections :

- Corrected command '-apply_pose3d'. Wasn't working with 3d objects having large textures.
- Corrected TIFF loader, ensuring that files without tag SAMPLESPERPIXEL defined, can be read correctly.
- Fixed issue with using backslash characters in text fields for filters in Faves.
- And many other corrections of small bugs.
admin
Ronounours 5 years ago
* Updated 2011/11/28 : Final release.
MOD
lylejk Posted 5 years ago. Edited by lylejk (moderator) 5 years ago
Below's a repeat of what I wrote at GIMPChat:

OK; noticed that the size of curl.exe changed so replaced it, but then I couldn't get internet updates (G'MIC did a quick try, then stopped). Went back to the older version of curl.exe and still the same behavior. Now I don't see any of the custom presets like from PhotoComix or Tom. Just passing that info on. :)
karo03 5 years ago
Hi Lyle, you should locate the (dot) gmic files and rename them deleting the leading dot. Under XP they are under "Application Data", under Win7 they are under AppData\Roaming located.
Karsten
MOD
lylejk 5 years ago
Don't know exactly why, but after clicking the custom presets for the authors and refresh, it worked. Something similar to this happened several generations ago so maybe I subconsciencely remembered this and did this. Every thing's fine now. Rod already alluded to the .gmic to just gmic change at GIMPChat. Glad that was done; don't like filenames that begin with a dot (might be my personally bias; lol). Now to convince the GIMP folks to change their folder name for GIMP (fat chance; lol). :)
PhotoComix_Mandala 5 years ago
you show black and white plasma i was more focused on the colored plasma as in the plugin
and in the plugin changed the most evident diffrence for me is that colors are lighter and semitransparent:
i suppose now also alpha is random and that can make sense even if the result at the first is surprising.

@Lylejk

"Now to convince the GIMP folks to change their folder name for GIMP (fat chance; lol)"

Why not call the (Windows )gimp user folder "gimp_user_folder"?
Maybe one day Science will shred a light on such mystery !
admin
Ronounours 5 years ago
Now, the plasma has a new option 'Transparency', so you can choose if you want to have transparency or not for the plasma effect.
PhotoComix_Mandala Posted 5 years ago. Edited by PhotoComix_Mandala (member) 5 years ago
ohh thank that is cool !
i like transparency and i do like even more both option available

now both the result and preview change, but the changes in the preview remain unrelated to the changes applied to the image

preview works only the first time, clicking apply the preview went totally unrealable

maybe when randomness is applied preview command and command for render don't use the same seed ?
admin
Ronounours 5 years ago
A random process indeed uses a seed to generate random numbers so we could use the same seed for the preview and the generated image, but still, there is no way the preview could be close to the final result, since both have different size, which mean they use a different number of random values, so generated random values won't fit spatially between the preview and the final image.

This is a random process. The only thing that could be done would be to generate a preview with the same size as the final image (and use the same seed), then reduce the preview. This is not possible since the plug-in does not know about the size of the final image when generating the preview. The G'MIC process only knows about the preview size when generating the preview.
PhotoComix_Mandala Posted 5 years ago. Edited by PhotoComix_Mandala (member) 5 years ago
force a 100% preview will not solve ?

I mean set as default zoom at 100% if the filter use "randomness"
admin
Ronounours 5 years ago
Even if the preview is at 100%, which means 'size of 1 pixel of the preview = 1 pixel of the image, it doesn't mean the preview size is the same as the image size. Only the resolution fits, not the size.
Partha at gmail 5 years ago
Hi All,

Uploaded G'MIC 1.5.0.7 for Windows 64-bit (and 32-bit) for all my builds.

Thanks,
Partha
MOD
François Collard 5 years ago
Tried to install it using your installer (64-bit version), even renamed definition files without dots, but it would never start. The message only told it could not start. So I'm back to the previous 1.5.0.6, using th 7z version. (Windows 7 64-bit 4 GB RAM i7 2600K 3.4 GHz)
PhotoComiX 5 years ago
no time now but i may try tonight the 64bit
MOD
François Collard 5 years ago
Tell us whether it works on your machine, Carlo, please. I bet it won't;)
PhotoComiX 5 years ago
Francois
i could not try the installer but the zipped version works

Well it contain also bashcompletation .exe that open a console at loading time and is not needed by the plugin, but works

let me try to refresh now .... good no error for internet updates

It does work

Francois try the zip (i could not look in the installer file except then creating a bogus gimp 2.7.4 in program files)
humm first you may wish remove bashcompletation .exe from the zip
Partha at gmail 5 years ago
@Francois, no error messages whatsoever?
MOD
François Collard Posted 5 years ago. Edited by François Collard (moderator) 5 years ago
No error message. Only something like "could not start". I'll try with the zipped version.
Same error (0xc000007b), with a French message that means "Application could not start properly".
Partha at gmail 5 years ago
@Francois,

Just to be on the safe side, I uninstalled my G'MIC 1.5.0.7. Then I downloaded the 64-bit version from my website and installed it on my computer.

I didn't have any issues. Here is a screenshot:
gmic-1.5.0.7 Screenshot

hmm, there may be some interference that is preventing it from starting?
PhotoComiX 5 years ago
Francois did you try to download again.
i tried again for me does work
MOD
François Collard Posted 5 years ago. Edited by François Collard (moderator) 5 years ago
I tried almost four times. I suspect a dll conflict somewhere. My Gimp is not the latest one (Gimp-2.7.exe dated 2011/09/17), and I dare not change it as I've patched some files in order not to have a black console or deprecation warnings. I only changed the curl exe.
At last, I tried with the version that has a 2.8 preview splash, and I got the same error, even if I delete the whole bin directory before installing.
I suspect some dlls still in my .gimp-2.7 dir...
NO. This is a rather tricky error.
BTW, I suppose I forgot the way to start gimp with console massages. gimp-2.7.exe --console-messages does not display anything more than clicking the program icon.
Partha at gmail 5 years ago
Francois,

I removed the console since there was a lot of request to get rid of it. Hence you don't see anything more than clicking the program.

Have you tried one of my portable Gimp versions to see if there is a DLL conflict on your side?
MOD
François Collard Posted 5 years ago. Edited by François Collard (moderator) 5 years ago
But in the former versions, the --console-messages switch brought the console back. I have just tried: "Gimp-2.6 --console messages" opens the console.
I installed your latest version, as you tell me you get no error with it.
I suppose that if I change byte DC in the Gimp executable from 02 to 03, I'll get a console again; but without messages, I fear. The byte at 02 means a Windows PE.
The console works indeed when the byte is set to 03, but no special error message is sent when Gimp tries to open G'mic. The messages from the console seem nearly "normal":
This is a development version of GIMP. Debug messages may appear here.
(gimp-2.7.exe:5068): LibGimpBase-WARNING **: gimp-2.7.exe: gimp_wire_read(): error
(gimp-2.7.exe:5068): LibGimpBase-WARNING **: gimp-2.7.exe: gimp_wire_read(): error
(gimp-2.7.exe:5068): LibGimpBase-WARNING **: gimp-2.7.exe: gimp_wire_read(): error
(gimp-2.7.exe:5068): Gtk-WARNING **: Could not find the icon 'image-jpeg'. The 'hicolor' theme was not found either. you need to install it.
You get a from: icon-theme.freedesktop.org/releases
Groups Beta