Discussions (918)

Release of G'MIC 1.4.7.3

view profile

Ronounours is a group administrator Ronounours says:

I'm happy to announce the release of the 1.4.7.3 version of the G'MIC package. Here is the Changelog (compared to previous stable 1.4.7.2) :

* Bug corrections :

- Corrected bug in command '-graph'. Argument list was not recognized when drawing a graph with a specified color and a hatching style.

- Corrected : Key value of a closed display was not 0.

- Removed warnings when using the plug-in and GIMP 2.7.x

* New features :

- Added new command '-display_array' (eq. to '-da') which allows to locally explore pixel values of up to three neighborhoods of a 2d image.

gmic_display_array by Ronounours


- Added new layer merging mode 'Grain merge' and 'Grain extract'.

- Updated distance transform function '-distance', so that it can use different metrics : Manhattan, Chebyshev, Euclidean and Squared-Euclidean. Thanks to Arnold Meijster for his contribution for the CImg library.

- Updated component labeling function '-label'. It can now compute labels in 2d and 3d, and can consider low or high connectivities (4/8 in 2d, or 6/26 in 3d). Thanks to Arnold Meijster for his contribution for the CImg library.

- Added 3d view (that can move) when displaying 3d volumetric images. The 3d view displays the 3 projections planes XY, XZ and YZ in a wireframe cube, so you can see where you are located in the volume. Here is a screenshot of this new feature (the lower-right part of the image) :

cimg3d by Ronounours


3D view can be activated using shortcut 'CTRL+V'.

* Optimizations / modifications :

- Recoded part of the image display function to be more user-friendly.

- Remove one possible option for command '-split', concerning the splitting of images into patches. It was unused, hardly usable and can be done in other ways. This allows to lighten the source code a little bit.
Originally posted at 6:36AM, 7 January 2011 PDT (permalink)
Ronounours edited this topic 69 months ago.

view photostream

Ronounours is a group administrator Ronounours says:

* Final release, 2011/01/14
69 months ago (permalink)

view photostream

marossiotes says:

Ok,
no warning with gimp 2.7.2 and gmic_gimp 1.4.7.3.
69 months ago (permalink)

view photostream

Ronounours is a group administrator Ronounours says:

sweet :)
69 months ago (permalink)

view photostream

lylejk is a group moderator lylejk says:

Thanks again David. I know of a lot of jealous PS users that envy for G'MIC. Even got one of them to actually install GIMP and G'MIC because of the color transfer preset (see link below and scroll). :)

www.retouchpro.com/forums/photo-retouching/32101-imitate-...
69 months ago (permalink)

view photostream

Ronounours is a group administrator Ronounours says:

You're a perfect evangelist Lyle, thanks for your incredible support !

:)
69 months ago (permalink)

view photostream

Ronounours is a group administrator Ronounours says:

Sorry, but I had to make a quick fix to 1.4.7.3, so I've released one new package with the same name.
69 months ago (permalink)

view photostream

lylejk is a group moderator lylejk says:

The presets that I have used (just created the Splash Skull a little earlier with it) went flawlessly, but I'll download 1.4.7.3 again. :)
69 months ago (permalink)

view photostream

Forest (GKweb.it) says:

Thank you! No problem with Gimp 2.6.8 on Mac OSX 10.6.6.
68 months ago (permalink)

view photostream

OmTeFotograferen says:

Can't "make" 1.4.7.3 on Ubuntu 10.10 AMD64

gmic_gimp.cpp: In function ‘void process_image(const char*)’:
gmic_gimp.cpp:1788: error: ‘gimp_image_get_item_position’ was not declared in this scope
gmic_gimp.cpp:1804: error: ‘gimp_image_insert_layer’ was not declared in this scope
gmic_gimp.cpp:1839: error: ‘gimp_image_insert_layer’ was not declared in this scope
gmic_gimp.cpp:1872: error: ‘gimp_image_insert_layer’ was not declared in this scope
make[1]: *** [gmic_gimp] Error 1
make[1]: Leaving directory `/home/mark/Downloads/Gimp/gmic-1.4.7.3/src'
make: *** [gimp] Error 2
68 months ago (permalink)

view photostream

Ronounours is a group administrator Ronounours says:

What is your version of GIMP ? isn't it 2.7.1 ?
68 months ago (permalink)

view photostream

OmTeFotograferen says:

Yep. It did work before with 1.4.7.0 as per your instructions.
68 months ago (permalink)

view photostream

OmTeFotograferen says:

Gimp version listed as Gimp 2.7.2 (from within Gimp, in the package manager it is referred to as 2.7.3-mm)

Installing the 1.4.7.3.deb for amd64 works, but keeps giving the error message. Got rid of that by "make" gmic myself before.

WARNING: Plug-In "gmic_gimp"
(/home/mark/.gimp-2.7/plug-ins/gmic_gimp)
called deprecated procedure 'gimp-drawable-is-valid'.
It should call 'gimp-item-is-valid' instead!
Originally posted 68 months ago. (permalink)
OmTeFotograferen edited this topic 68 months ago.

view photostream

Ronounours is a group administrator Ronounours says:

Well, there has been several changes in the GIMP API recently, and I tried to adapt the code of the G'MIC plug-in to get rid of the warnings... It seems your API version of GIMP fits the version tests I've done in the source code, but are in fact older (or newer) thant the API I'm based on.
68 months ago (permalink)

view photostream

OmTeFotograferen says:

I found some strangeness in the packages (for my Ubuntu version).

It seems the last update is dated 5 nov 2010, but my latest version seems from july 27.

I thought of starting to build Gimp myself, but I'm unsure wether that will actually help.

Anything I can help with or you need to know?
68 months ago (permalink)

view photostream

marossiotes says:

@OmTeFotograferen
gimp api are changed in ~october 2010,without changing the micro version of gimp, (2.7.2)
you need an updated versioni of gimp 2.7.2 git

git.gnome.org/browse/gimp/log/?ofs=350

Could be this:
launchpad.net/~alex-p/+archive/notesalexp/+packages
i don't now , i'm using debian with gimp build myself.
Ubuntu ppa repos are a mess.
Originally posted 68 months ago. (permalink)
marossiotes edited this topic 68 months ago.

view photostream

marossiotes says:

@OmTeFotograferen

this is a gmic_gimp 1.4.7.3 plugin for linux 64, build myself with the original gmic 1473 sources, and gimp 2.7.2 dev files

www.mediafire.com/?uf4z8tjcrf4v7yb

none
"called deprecated procedure 'gimp-drawable-is-valid'"
warning
Originally posted 68 months ago. (permalink)
marossiotes edited this topic 68 months ago.

view photostream

OmTeFotograferen says:

It may have to do something with amd64 as well, which also happens tyo be my base. I saw build failures in the launchpad link as well.

Still haven't build Gimp myself, by lack of detailed instructions and seeing other have trouble with it. Not sure if there is a way back, since there are many dependencies and other things to build as well.

Rather cope (or redirect) these errors for a bit, or would you suggest otherwise.

Should try to install your gmic version first I guess.

Edit: started using your Gmic. No "drawable" warnings anymore.
Originally posted 68 months ago. (permalink)
OmTeFotograferen edited this topic 68 months ago.

view photostream

marossiotes says:

@OmTeFotograferen

ok,
because the plugin was built with the correct version of libgimp

(sorry for my poor english)
Originally posted 68 months ago. (permalink)
marossiotes edited this topic 68 months ago.

view photostream

OmTeFotograferen says:

Meanwhile, I talked to Matt Walker, who manages the probably wellknown Ubuntu PPA for Gimp 2.7 (mrw-gimp-svn for matthaeus123)

He's looking into compiling the newer gimp version and checking for the errors as well as trying to find out why python never worked with the development version.
68 months ago (permalink)

Would you like to comment?

Sign up for a free account, or sign in (if you're already a member).