(1 to 100 of 178 replies)
Sorin LS 10:48am, 20 December 2011
changes: warm white balance, astro noise reduction, browser improvements
when installing it asks for which version to install: x32 or x64 but if you have Color Efex you can only use x32 version

EU links: nikonimglib.com/cnx2/index_en_eur.html
1
(1 to 100 of 178 replies)
Jens N. Roved PRO 6 years ago
Thank you!
Sorin LS Posted 6 years ago. Edited by Sorin LS (member) 6 years ago
Testing it a bit, there is a visible speed increase. I've installed the x32 version o win7 x64. There isn't MT on all cores but it's faster and loads images with many edits a lot faster
MOD
PMLPhoto 6 years ago
I'm also trying it out - agree with Sorin, first impression is that it is a lot faster rendering when there are lots of edit steps, and is also more respsonsive when making changes to a step when there are lots of steps.
E & MS 6 years ago
It says this is a trial version, I assume it is a beta & an approved version will follow?
Jens N. Roved PRO Posted 6 years ago. Edited by Jens N. Roved (member) 6 years ago
Time to test some of your presets on it, Sorin. ;)
Jens N. Roved PRO 6 years ago


Just go to your local Nikon website and download it from the support area there.
MOD
PMLPhoto Posted 6 years ago. Edited by PMLPhoto (moderator) 6 years ago
E & MS It's just that Sorin gave a link to the page that has the free trial version, this is a proper release, and Nikon's trials are the full releases. As far as I know they do not do open releases of Betas. Have a look here for the "non-trial" version. Phil
PiotrAF. 6 years ago
WOW! This is amazing! Since I own CEP3, I had to install the 32-bit. I had 1 strange file. It used to create a ~5GB cache while opening and thus it took over 10 minutes to initial open! Not to mention the disk space needed. I opened it with the version 2.3.0 not even from the local disk but from external USB2 disk - it took about 12 seconds!! to see the initial photo and total 20 sec to open completely !!!!!!!!!!! Changing version 20 sec each - previously about 5-10 minutes with this specific file! Then I saw that default cache is not enabled so I checked to enable, and it took even less 15sec!! both open and change version!
Great work Nikon! Thanks for notifying!
John the Photographer Posted 6 years ago. Edited by John the Photographer (member) 6 years ago
Bad news. I installed the 32 bit version since I have CEO3. CNX now won't open any files with CEP3 steps. If I attempt to use CEP3, CNX2.3 crashes. Any ideas???

I uninstall and re-install CEP3, no luck :(
PiotrAF. 6 years ago
Cannot confirm - everything here work's better than fine :-) Windows 7 64-bit, 32-bit CNX2.3 + CEP3

The other good news is that bird's eye view seems to utilize the monitor color profile at last!
nikovan 6 years ago
FYI - ViewNX 2.2.5 is also out!
MOD
PMLPhoto 6 years ago
John the Photographer What sort of crash and error message (if any) are you getting?

It's working fine for me - Windows Vista 32 bit and CEP 3.

The only issue I had was CNX complained about not being able to open TIFF thumbnails in the browser. I deleted the file C:\Users\Phil\AppData\Local\Nikon\CaptureNX\ThumbnailCache that existed under 2.2.8, and 2.3 created a ThumbnailCache directory as it needed, and all now works fine.

Phil
Jens N. Roved PRO 6 years ago
Same here. Any CEP 3.0 setting will crash CNX2.
Sorin LS 6 years ago
CEP works here.
GeneInman.com PRO 6 years ago
FYI - As a precaution, I have re-downloaded CNX2 version 2.28. The new version has not been posted on the Nikon USA site yet, but I want to have a way to downgrade if Ver. 2.3 becomes a problem.

In the past Nikon has kept the older version available for a while, but I don't want to take the chance that 2.28 will disappear down the road.
WestLothian 6 years ago
Same here. Any CEP 3.0 setting will crash CNX2.
Works for other NEF files but freezes at 75% for CEP 3.0.
Jens N. Roved PRO 6 years ago
Nope, that doesn't help...
Jens N. Roved PRO 6 years ago
Reverting back to 2.2.8 since I can't even open previous files that contains CEP3.0 filters. Talked to a Nikon supporter and they say that they don't know what the problem is but they are working on full Lion support. When I told her that 2.2.8 worked fine with Lion she said that then she doesn't know what the problem is. Wonderful! :/

Running CNX 2.3.0 in 64 bit mode in Lion doesn't give you the option of CEP3.0.

If you run it in 32 bit mode you get CEP3.0 in the application but when you try to click a filter it crashes NX2. Bloody long crash report too.
Sorin LS Posted 6 years ago. Edited by Sorin LS (member) 6 years ago
Is it a change in the Auto Retouch algorithm? It seems it clones the areas differently. Also there may be changes to the NR settings or the demosaicing algorithm because i really have the impression that noise had a different "look"

NR still seems to be the best MT function, 30-40% cpu, while the new Astro goes between 40 and 80% (cpu is 1090T).
PiotrAF. Posted 6 years ago. Edited by PiotrAF. (member) 6 years ago
Wacom Bamboo Pen&Touch - at last usable here. Previously it was too slow. Unfortunatelly I lost the pressure control and eraser ability. Colud someone confirm/deny having this problem? I'll try reinstalling the wacom driver - maybe it's coincidence only
Sorin LS Posted 6 years ago. Edited by Sorin LS (member) 6 years ago
Confirmed, pressure and eraser don't work here with bamboo. Other programs work fine with pressure and eraser, like Ps.
PiotrAF. 6 years ago
I tried simple reinstall with no luck so I found this
forum.wacom.eu/viewtopic.php?f=4&t=8164&p=33891&a...
and will perform as they advice and let you know if it helped.
P.S.
Anyone knows if pressure/erase should work in e.g. microsoft paint?
Sorin LS Posted 6 years ago. Edited by Sorin LS (member) 6 years ago
I don't think Paint has any input of this type
It seems that the eraser had problems before
forums.dpreview.com/forums/readflat.asp?forum=1006&me...

I've found some more info, it seems there were pressure problems with previous versions of CNX too, but all posts were from Mac users. What they did to fix the problems was just to uninstall then reinstall the wacom softare and delete tablet's preferences. Sometimes that didn't work so they installed older driver versions until one worked :D

This seems to be a CNX problem, all other programs work fine with pressure with the same driver
WernerG2011 6 years ago
Has anyone found a way to install 2.3 next to 2.28? I'd like to try the 64 bit version but I'm not willing to abandon CEFX. If you download the "trial" version, will it automatically replace 2.28? Is there a real benefit to V 2.3 / 32 bit?
Sorin LS Posted 6 years ago. Edited by Sorin LS (member) 6 years ago
I couldn't find a way to install multiple CNX versions. If it sees one it updates it. Thanks to Nik programmers you won't be able to start multiple instances of CNX either (like work in one, batch with another, the cpu stays mostly unused anyway)
PiotrAF. 6 years ago
true. I recalled I have a PSE10 trial installed and checked it there, works fine. The CNX2.2.8 the pressure was working AFAIR but since it was too slow on my machine I used the mouse instead. I like it better now and wait for them to fix it, although I'll try to report it somewhere.
As to 64-bit/32-bit CEP3 I'm not sure it's NIK's fault. When I asked NIK about CEP4 for CNX2 they replied that they're unable to make CEP4 for CNX2 unless Nikon gives them permission. Unfortunatelly I lost the email somehow so I just recall from memory.
John the Photographer Posted 6 years ago. Edited by John the Photographer (member) 6 years ago
OK. This is very disturbing. I am NOT alone in experiencing that CEP3 no longer works with CNX2.3. Basically, NEF files with CEP3 steps embeded will no longer open. I get a black window with the open file icon spinning forever. I can open a nef file BUT whenever I select a CEP3 step, CNX crashes with the Windows message saying that Capture NX 2 is no longer working. Click OK and the app closes.

Out of desperation, I un-installed EVERYTHING so that there is no trace of CNX on my Windows 7 64 bit OS. I installed CNX2.3 from ground up. The install DID NOT ask me if I want 32 or 64 bit. So the install proceeds to install a 64 application. This means that I am NO LONGER able to install CEP3 as CEP3 looks for the presence of 32 bit CNX2.

I'm extremely disappointed with Nik. They can't even get their own software to work togather. Let's hope that Nik will come up with a 64 bit version of CEP3 although it is highly unlikely as they no longer support CEP3. Not sure if CEP4 will work with CNX2.3 64 bit.
MOD
radiorabbi 6 years ago
In the past I found CNX2 would stop responding when Memory usage approached 2.6 gig with the OS and other stuff using about half of that

now running flawlessly well beyond that

running on widows Vista 64 bit

so far i call this an improvement

i guess this proves Nikon really is abandoning Capture NX
{:-)
Jens N. Roved PRO 6 years ago
You can work 2.3.0 if you erase all traces of CEP3.0 and the reinstall CNX2.3.0 from scratch but then you will not have CEP3.0 at all. Time for Sorin to give us all the CEP3.0 filters as setting files. ;)
Jens N. Roved PRO Posted 6 years ago. Edited by Jens N. Roved (member) 6 years ago
Sorin LS says: "CEP works here."

What kind of system are you running? I tried to remove everything and do a clean reinstall on my system and it still doesn't work with CEP3.0.
Sorin LS Posted 6 years ago. Edited by Sorin LS (member) 6 years ago
@John the Photographer : I think that, since you say v2.3 won't ask x32/x64 anymore, you must go back to previous CNX version, install CEP for it and only then try to upgrade CNX.

The other solution requires a virtual machine so you can have at the same time 2.3 x64 and 2.2xx with CEP x32.

@Zubair-Roved Productions: win7 x64 with 2.3 in x32 version, same as PiotrAF above
Jens N. Roved PRO 6 years ago
Ok, it is quite strange that it doesn't work here...
Jens N. Roved PRO Posted 6 years ago. Edited by Jens N. Roved (member) 6 years ago
Going to try to install 2.2.8 and then reinstall CEP3.0 again.

Well, that is impossible... 2.2.8 is an update...
Jens N. Roved PRO 6 years ago
So bye bye expensive CEP3.0 filters...
Sorin LS Posted 6 years ago. Edited by Sorin LS (member) 6 years ago
Most of them are updates, you have to go back to the version which was full version, 2.xx don't remember which one. then update to 2.2.8, then install CEP, then leave it as is until Nik gets enough emails to find the fix for this problem
Jens N. Roved PRO Posted 6 years ago. Edited by Jens N. Roved (member) 6 years ago
Yeah, either that or just skip the CEP3.0 filters until they fix it since everything else is working fine.
njtrout_2000 PRO 6 years ago
Are we talking CEP 3.0 Capture NX version or CEP 3.0 called outside of CNX that is causing problems?
Jens N. Roved PRO 6 years ago
We are talking CEP3.0 not working inside CNX2.3.0. Anytime you want to use a CEP3.0 filter it crashes CNX2.3.0.
John the Photographer Posted 6 years ago. Edited by John the Photographer (member) 6 years ago
@njtrout It's CEP3 CNX version.

I cleared CNX from my machine. Installed 2.2.4 and CEP3. No problems there. Installed 2.3 32 bit and it goes bang again when creating a CEP3 step. Very frustrating.

I'm going to uninstall everything again and install 2.3 @ 64 bit. I will install 2.2.4 + CEP3 on a VM for now until there is a fix.

How sad.
PiotrAF. 6 years ago
Well, yesterday you lived without 2.3.0 so maybe you'll survive with 2.2.8 until the fix? Just as I have to survive without the pressure control for now. Although I filed a bug in nikon support. Do the same for your problem both with Nikon and NIK. They both need each other in order to gain and not to loose customers, so let's hope they'll manage to do something.
Jens N. Roved PRO Posted 6 years ago. Edited by Jens N. Roved (member) 6 years ago


Well, I found a 2.2.4 download so I am going to play around with 2.3.0 for a bit and see if it is better than 2.2.8. I can do with Sorins presets for now. If 2.3.0 is more stable I may stay with it and wait for a fix on CEP3.0 for 2.3.0 for Mac. If not I will just revert to 2.2.8 and reinstall CEP3.0.

But it is disappointing that Nikon releases a product that is not compatible with their own filter effects software which in itself is a 250$ product that they just render obsolete by 1 single update without any warning.

P.S.: I already sent them a crash report.
John the Photographer 6 years ago
I find that 2.3 is more stable and runs smoother especially in 64 bit. I'm going to stick with 64 bit until a fix is released. I'll log fault with Nikon also.
JackHo9 6 years ago
Didn't ask me to choose 32 vs 64 bit, it simply installed itself as 64 bits all by itself. It asked for my CNX2 upgrade key only, no problems there.

MUCH faster :-)
John the Photographer 6 years ago
If you do not have CEP3, the install will proceed as 64 bit.
WestLothian 6 years ago
I installed the 32bit version as prompted.
After the crash I get Windows 7
"Problem Event Name: BEX" whatever that means?
Memory management issue perhaps?

I raised a Nikon Support Question.
Photeinos 6 years ago
I have downloaded View NX 2.2.5 from the Nikon Europe site twice now and each time it loads up as 2.2.3? What is going on?

Paul
PiotrAF. 6 years ago
Nikon and NIK are 2 completly different companies. www.niksoftware.com/company/usa/entry.php?info=company/pr... .
They would both survive cease in cooperation, although loosing money ath both sides, but we'd be the real loosers, especially those of us who just paid them money recently.
JackHo9 Posted 6 years ago. Edited by JackHo9 (member) 6 years ago
Just for kicks, I retried the speed test:
42 vs 55 seconds (when last run with version 2.2.6), similar HW configuration - see the link above for details. Thank you Nikon!
thor_mark  PRO 6 years ago
I'm curious as to which OSs are having the issue with the new Capture NX 2 and CEP 3. Is it Windows, Macs or both? I'd like to run the installation tonight on my Mac but don't want to sacrifice CEP 3 either. Just asking...
PiotrAF. 6 years ago
All this is scary. I think I will have to recall from memory all the files that used CEP3 and export them to tiff additionally in order not to loose my work in case they ever decide to cease cooperation.
Escy Posted 6 years ago. Edited by Escy (member) 6 years ago
If you do not have CEP3, the install will proceed as 64 bit.

I had CEP installed but it didnt ask whether to install 32 or 64, it just went ahead and installed 64, so ive lost my CEP...
Jubilantgnome Posted 6 years ago. Edited by Jubilantgnome (member) 6 years ago
I have a Mac running Os 10.7.2

I removed NX 2.2.8 and installed 2.3. Then installed the latest version of Color Efex 3.03

NX2 opened and works nicely in 64 bit mode but the Color Efex filters were not even visible.

When I then ran NX2 in 32 bit mode, NX2 and Color Efex 3 work smoothly.

I tested this on my Mac Book 2.4 GHz Intel Core 2 Duo and am sufficiently confident to now do the same on my 2006 Mac Pro.
thor_mark  PRO 6 years ago
to Jubilantgnome:

When you mentioned the 32 & 64 bit running, is there an option for the installation to install both? Or is that option with two programs (32 bit & 64 bit) in the Applications folder?
Jubilantgnome Posted 6 years ago. Edited by Jubilantgnome (member) 6 years ago
Thor-mark

The install will install both. After installation, if you "Get Info" on the application you will see a box to open in 32 bit mode. 64 bit is the default.

To "Get Info"

There will be a Nikon Software folder in Applications. Open that folder to see the application. Do a right click or option-click on that app and select Get Info.

Or, do a right or Option click on the NX2 icon in the Dock, choose Options>Show In Finder and do another right or option click on the app to Get Info.
PiotrAF. 6 years ago
[OT] A question to those of you who cannot run CEP3 now:
In such case, do you loose the ability to open the file at all, or it opens in other version or the same version but the plugin steps are not active? I never tried opening such file without CEP3 and I'd like to know if I loose completely the file/version or only a setting e.g. tonal contrast won't be active?
MOD
PMLPhoto 6 years ago
As mentioned above earlier by me, no issue here on a 32 bit Vista Home Premium SP2 - CNX2.3 and CEP3 play very nicely together.

Just checking, but do those who are having problems have the relevant OS service patches installed. Nikon says they need:

Microsoft Windows 7 (SP1)
Microsoft Windows Vista (SP2)
Microsoft Windows XP Professional (SP3, 32 bit only)
Microsoft Windows XP Home Edition (SP3, 32 bit only)

- Pre-installed versions only.

- Compatible with both 32 and 64-bit versions of Windows 7 and Vista.

Or Macintosh OS X versions 10.5.8, 10.6.8 and 10.7.2
JonBauer PRO 6 years ago
Yeah, looks like Nikon USA screwed up the View NX2 2.2.5 Mac download too. I always get 2.2.3.

- Jon
WestLothian 6 years ago
In Windows 7 for me the whole program freezes if you try to access any CEP3 features; old in the NEF, or new steps.
Sorin LS 6 years ago
@PiotrAF: if you open a nef using Efex on a system without it installed, you get a message that some stuff is missing, or something like that, and the file will load fine, wihout the Efex edit steps.
ramblinwreck001 [deleted] 6 years ago
Interesting about CEP3 for CNX. The v2.3 update for the CNX2 User Manual does suggest that CEP for CNX _should_ work under 32-bit, for both Windows and Mac.

Quote:

------------------------------
Windows

Capture NX 2 now requires a minimum of 1 GB of RAM (2 GB or
more recommended) and runs as a native 64-bit application in
Windows 7 and Windows Vista (User’s Manual, page 11). When
installing Nik Color Efex Pro™ 3.0 for Capture NX 2 under 64-bit
Windows, you will be prompted to choose between the 32-bit
and 64-bit versions; choose the 32-bit version.

Macintosh

Capture NX 2 now requires a minimum of 1 GB of RAM (2 GB
or more recommended) and supports Mac OS X versions
10.5.8, 10.6.8, and 10.7.2, in which it runs as a native 64-bit application
(User’s Manual, page 11). Nik Color Efex Pro™ 3.0 for
Capture NX 2 can only be used when Capture NX 2 is running
in 32-bit mode: quit Capture NX 2, select the Capture NX 2 application
icon, choose Get Info in the Finder File menu, and
choose Open in 32-bit mode.
------------------------------

Link:
www.nikonsupport.eu/europe/Manuals/zmapkjhqoi//D-CNX2AUM-...
PiotrAF. 6 years ago
Thanks. That's a bit less scary :-) I'll give the 64-bit a try then :-)
Andrew Stawarz PRO 6 years ago
Same problem here with CEP3 on 2 Windows 7 x64 systems updating a NX 2.2.8/CEP3 installation to 32-bit 2.3. Files taking in inordinately long time to open (or just hangs NX) if they contain CEP3 steps or application exceptions when adding CEP3 steps to a fresh file.

Looks like I'll be rolling back to 2.2.8, lucky I still have the 2.2.6 full and 2.2.8 update files.
PiotrAF. Posted 6 years ago. Edited by PiotrAF. (member) 6 years ago
Great news Windows 7 64-bit guys with CEP3 :-)
If you installed the 32-bit CNX2-2.3.0. Go to "Program Files (x86)\Nikon"
"Program Files (x86)\Common Files\Nikon" and create a backup copy of each "Capture NX 2" folder. Then run the install again. You will be prompted if you are sure you want to install even though you have the same version - choose yes and 64-bit. Run CNX2 with your serial and exit. Go to the "Program Files (x86)\Nikon"
"Program Files (x86)\Common Files\Nikon" and rename the "Capture NX 2" e.g. "Capture NX 2_leftovers_x64" just in case, then copy the backup version and name it "Capture NX 2" in each folder. If you had a shortcut on desktop or wherever it should be still there only without an icon, if not, create one to "C:\Program Files (x86)\Nikon\Capture NX 2\Capture NX 2.exe" and run it, and voila! you have both versions coexisting, running and CEP3 if needed running in the 32-bit CNX2!
Of course this is at your own risk! My run smoothly although I don't see any speed improvement between these two :-)
P.S.
It might be safer/better to make backup of the whole Nikon folders since the 64-bit also installs e.g. picturecontrol 64-bit etc.
I ran a test suggested by with both versions of CNX 2.3.0 - the result :
x86 1:20
x64 1:06
After some calculations, how much time it could save me, I decided not to keep the x64 even though it is faster :-)
Joesboy Posted 6 years ago. Edited by Joesboy (member) 6 years ago
Macintosh

Capture NX 2 now requires a minimum of 1 GB of RAM (2 GB
or more recommended) and supports Mac OS X versions
10.5.8, 10.6.8, and 10.7.2, in which it runs as a native 64-bit application
(User’s Manual, page 11). Nik Color Efex Pro™ 3.0 for
Capture NX 2 can only be used when Capture NX 2 is running
in 32-bit mode: quit Capture NX 2, select the Capture NX 2 application
icon, choose Get Info in the Finder File menu, and
choose Open in 32-bit mode.

Works like a charm, what a relief, thanks
Jens N. Roved PRO 6 years ago
It still doesn't work on my Mac even though I did a clean install.
Retlas 6 years ago
Just joined the group and updated to 2.3.
Running Mac — 10.6.8 Snow Leopard. and everything is fine and MUCH faster.
Not using any plugins though — just the standard software. Hope everyone can solve their problems!!
Probably not helpfull if you are encountering trouble but — hello everybody.
Dan Irving Posted 6 years ago. Edited by Dan Irving (member) 6 years ago
In the "Important Information" section that pops up at the start of the installation process, there are about 16 or so points that are mentioned. I've copied an excerpt from this.

Note point # 13:

---------------------------------------------
12. If you save NEF/NRW images with “Thumbnail Only” selected for the “Embed Preview When Saving NEF” option on the “General” page under “Preferences”, that will cause some impact on displaying and printing the NEF/NRW images with the application listed below.
- ViewNX 2
When viewed in Image Viewer or printed, NEF/NRW images that were saved with Capture NX 2 will appear in low resolution.

13. Color Efex Pro 3 is not available with Capture NX 2 Version 2.3.0.

14. Updating Capture NX Version 2.2.8 or earlier to Version 2.3.0 will clear the “Use Image Cache” checkbox in the “Editing Cache” section on the “Cache Settings” page under “Preferences”.
--------------------------------

It's a shame they don't mention that bit of info on the release notes on the Nikon website.

BTW- I'm running on OSX - 10.7.2
PiotrAF. 6 years ago
[OT] I read you're running Win7 64-bit with 3GB ramdrive. 2 questions: 1) did you (or could you) check speed with and without ramdrive? 2) what software did you use to create ramdrive? Previously I once tested it seeking help with a problematic file, but since it grew to absurd size of 5GB I never really had a chance to test it, with this version this might be worth buying more ram if the ramdisk will speed up.
Jens N. Roved PRO 6 years ago


Did you try to use the filters yet? Because it still doesn't work here even after a clean install of the OS.
Joesboy 6 years ago
MAC OS 10.6.8 setting 32 bit mode allow CEP filters to be seen but trying to use them crashes CNX and I can't seem to get back to 2.2.8
Also having major grief with VNX, download 2.2.5 but 2.2.3 is what gets installed
looperp55 6 years ago
I just updated VNX2 and NX2 with CEP 3.0 and I tested them with nef files previously worked on with CEP 3. They work perfectly with CEP 3 and faster.

Win 7 64 bit with 32bit NX2 2.3
Jubilantgnome Posted 6 years ago. Edited by Jubilantgnome (member) 6 years ago
Zubair - Roved -Productions.

Yes. I tried several filters , Stylizing and Traditional, and they worked on a NEF from a D300. I did uninstall 2.2.8 before installing 2.3 ,as recommended by the installer.

Other than deleting all NiK and CNX2 preferences I do not know what to suggest.

EDIT: I did download and install a new copy of Color Efex 3 from Nik software. Perhaps that will help. I just followed the same procedure on my Mac Pro and everything is working smoothly.


Good luck.
nwcs0822 [deleted] 6 years ago
I don't know if anyone else has run into it but when I installed the 2.3 updater it made me re-enter my NX2 key and NX1 key! Glad I had them handy or I'd be sunk.

I have to say they really did speed it up this time. Noticeably better.
thor_mark  PRO 6 years ago
To ubilantgnome: thanks! What you pointed out with the 32 bit selection, uninstalling and installing worked just fine. I just wish I could download the 2.2.5 version of View NX for Macs now...
Catallaxy0 6 years ago
For those who are planning on doing the upgrade, can you please run the speed test before and after the upgrade and post your pre/post upgrade scores in that thread?

Also please note your OS version and service pack - as that may help us figure out if there is a problem with a specific OS or service pack for CEP filters not working.

I am running out for a bit, but will upgrade later tonight after running the speed test.

Speed Test:
www.flickr.com/groups/capturenx/discuss/72157622026251465/
Bill-S2001 PRO Posted 6 years ago. Edited by Bill-S2001 (member) 6 years ago
CEP NEF won't open. So I may uninstall the 32bit 2.3, installl 64bit abd reinstall 32bit in XPmode VM with CEP for now.

Speed test:

Reran before install:
Previous best : 57 sec
Pre Upgrade : 57 sec (I though previous best was 67, so no change)
Post Upgrade : 47.5 sec (one at 48, one at 47)

Speed increase seems real and significant. Will try again with 64bit.

64BIT results: 40 sec

EDIT: So when I paid attention and did the 16 bit Tiff save with color profile embed instead of NEF save, average dropped to 38sec in 64bit NX.
lexnikon 6 years ago
I've been reading posts in this group for many months and have learned a lot. Now it might be my turn to offer an insight into this problem with running CNX 2.3 and CEP3.0 under Win 7.

I run Win7, 64 bit and had VNX 2.2.3 and CNX 2.2.8 installed, with CEP3.0.

First, I updated VNX to 2.2.5. Then I updated CNX to 2.3.0. (I updated both because they both use the same new version of Picture Controls.) At this point I experienced what others have described above: CNX2 was opening photos very slowly, showing all white and then all black screens for a long time, then when I tried to use the Color Efex filters it was even worse and I had to force CNX2 to close using Task Manager. It seemed completely unusable.

My next step was to go the Nik site and download a more recent version of CEP 3.0 for NX2. (You can access this by downloading a free trial version, using your existing licence key.) Previously I was using version 3.002 and what I obtained was version 3.003.

I used Control Panel to remove the existing CEP 3.002. Then I installed the new v 3.003.

Since then, everything has been working smoothly - CNX2 and all CEP filters on both newly edited and previously edited NEFs. And there's been a dramatic increase in processing speed both with and without the filters.

So in summary:
Keep CEP in place so that you have the option to install the 32-bit version of CNX2. Update VNX2. Update CNX2, 32-bit. Get the latest version of CEP3. Uninstall CEP3. Reinstall latest CEP3.

Good luck!
MOD
PMLPhoto Posted 6 years ago. Edited by PMLPhoto (moderator) 6 years ago
lexnikon I am on CEP 3.003, and I am one of the ones having no issues at all. You could well be onto something.
RogerGW [deleted] 6 years ago
Jason Odell reckons CEP 3 will work with CNX 2.30 but only in 32-bit mode. See www.luminescentphoto.com/blog/2011/12/20/nikon-capture-nx... .

I'm waiting for some clarity to emerge before I even bother downloading CNX 2.30.

Roger
Bill-S2001 PRO 6 years ago
Well done lexnikon That is indeed the trick!!! Maybe also why Phil had no issues.

I didn't even bother to update to VNX2.5, and couldn't find the old CEP to uninstall (maybe the 64bit NX install removed it?). ANyway, so I just installed 32bit NX on top of the 64bit, then re-installed the 3.003 and voila. And the files ARE opening much quicker than previous.

Will have to play around now and see if all this boat rocking has destabilized the environment.....
MOD
PMLPhoto 6 years ago
RogerGW It's not a case of Jason reckoning it will work; it actually does work very well for me, and some others. From what says, sounds like the upgrade fixes things. Interested to hear if it works for others as well.
GeneInman.com PRO 6 years ago
lexnikon - you are a Prince. Thank You!

I spent 4 -5 hours today upgrading, down grading and p!ssing and moaning because I could not get CEP3 to work. After trying everything I could think of.. with no success, I downgraded back to CNX2 ver 2.28... but even that was not an easy task, as I had not kept a copy of 2.28... only the update that needed 2.26 to update.

And since I started with Capture NX1 I had to find a version of 2.26, then register it via CNX 1 then CNX 2, then update to 2.28. Was a very long process just to get back to where I started with 2.28.

After reading your post I thought I would give it one more try.
and it WORKED!! I think the key is to already have CEP3 installed (like you said) so you get the 32-64bit option when upgrading CNX2. Then un-installing CEP3 and reinstalling it. I tried this with version 3.002 of CEP3 with no luck, so yes you must also make sure you are installing the latest version 3.003

In Short - lexnikon's instructions work!
Jens N. Roved PRO 6 years ago
So where do we get this 3.003 version of CEP 3.0 for Mac?
GeneInman.com PRO 6 years ago
Sorry, Zubair... guess I should have said I'm on a Win7 64bit quad-core. But I think you can get it from Nik. If you are a registered CEP3 user.. just log onto your account at Nik's webpage
Jubilantgnome 6 years ago
Zubair:

www.niksoftware.com/cepnx/usa/entry.php

Download and install the trial. I did that and it did not ask me to re-enter my SN but perhaps have it ready just in case.
lexnikon 6 years ago
Thanks for the feedback PMLPhoto, D7KS2001 and Gene! It's good to know that this procedure has worked well for you. Very satisfying to give something back to a community that has, unknowingly, supported me so well in my learning in recent years.
Jens N. Roved PRO 6 years ago
Ok, trying it out.
Jens N. Roved PRO Posted 6 years ago. Edited by Jens N. Roved (member) 6 years ago
And it works!!

Bloody hell. I just spent an entire day working on this just because Nikon doesn't know how to inform people of using a newer version of CEP 3.0 that we have never been prompted to update... Christ.

In any case. Thanks a lot for finding that out, guys. Owe you one.
Jens N. Roved PRO 6 years ago
So yes. Confirmed. CEP 3.003 works with CNX 2.3.0 on Mac OSX Lion. But you have to make sure that you download CEP 3.003. Older versions will not work.
Jason Odell 6 years ago
CEP 3 definitely works for me in 32-bit mode on Mac Lion.
And you MUST have CEP 3.0.3 installed for it to work... otherwise everything dies.
Wow! ViewNX2 loads in no time flat. Will have a good play with these tomorrow but so far no probs
filstermgr Posted 6 years ago. Edited by filstermgr (member) 6 years ago
Seeesh.... now I'm wondering what I missed out on running 3.002 :-)

Was able to download the 3.003 update thanks to your link Jubilantgnome. Nothing on Nik's normal home page for NX users apparently.

Anybody having issues with CEP3 after updating NX2 on XP Pro SP3?

BTW not using ViewNX.

Regards,
Frank
silverwolfe PRO Posted 6 years ago. Edited by silverwolfe (member) 6 years ago
found this, at the end of his review, he talks CEP3 being 32, & about how to toggle b/t 32/64 to use CEP3. luminescent blog

edit: oh, there's Jason, right up there...
and oops, this was already covered lol.
;))
Catallaxy0 6 years ago
Lexnikon is my hero - well maybe second after the fantastic programmer that wrote these updates!

PC:
Intel i7 860 at 2.8 Ghz
8 GB memory
Windows 7 x64 SP1

Starting Versions:
Capture NX2 2.2.8 (32 bit)
View NX2 2.2.3
CEP 3.002

Ending Versions:
Capture NX2 2.3 (32 bit)
View NX2 2.2.5
CEP 3.003

Starting Time for speedtest: 56 seconds
Ending Time for speedtest: 41 seconds
Speed Improvement: 27% faster.

This is like buying a new top of the line processor for my computer and that means that I don't have to plunk down that $500 for a new processor and motherboard this year. If NIK Software is reading this, they need to take note. If they can update CEP to 4.x for Capture NX2 64 bit, I am willing to part with the cash.

CEP 3.003 works fine. Opens very fast.

I have a hectic day tomorrow, but I will try to do some editing for a shoot that I completed this weekend and post my impressions on the NR and Picture Control Changes - if any.

Anybody have any problems printing? Just asking.
GroovyGeek 6 years ago
PiotrAF:
Can you clarify your procedure for keeping both 32bit and 64bit NX2 side by side?

The initial steps are clear: install 32bit then create copies of the two Capture NX folders, then run the installer once again and install the 64bit version.

However, after that it gets a bit murky (for me), starting at "rename the "Capture NX 2" e.g. "Capture NX 2_leftovers_x64""
cebuphotographer PRO 6 years ago
Another successful install of NX 2.3 with CEP 3.003 on windows 7 64-bit machine (installed in 32-bit mode so that CEP would still work). First file I opened was on that had CEP filters and a noise reduction step applied which usually takes NX a long time to render so I can start working. in NX 2.3 it opened almost instantly and when I zoomed in to 100% the rendering was very fast. So it seems there are definite speed improvements. Lets hope it doesn't come with sudden crashes later on, but so far, so good!
Andrew Stawarz PRO 6 years ago
Hit the same problems when updating a 2.2.8/CEP3 install to 2.3 x32 on a Windows 7 x64 system with crashing when adding CEP3 steps and long opening times. updating from CEP3.002 to CEP3.003 seem to be the cure for these situations. Found CEP3.003 when I went back to the product registration page on Nik's website.

Have to say, NX feels like a different beast, great performance improvements.
filstermgr 6 years ago
Updated CEP3 to v3.003 first, then installed CNX update. On Win XP SP3 there were no issues, CEP3 worked as expected.

FWIW I noticed Picture Ctrl Utility was updated as well, from v1.2.2 to v1.4.0.
WestLothian 6 years ago
Thanks again to Lexnikon. Freeze problem is cleared now on my installation.
John the Photographer 6 years ago
A bit OT but I have to say this. To the critics who say CNX2 is dog slow, I guess that's no longer valid, especially with the 64 bit version. As for the GUI, I find CNX2 to be more intuitive than PS or Lightroom. Each to his own of course.

I think we're going to see CNX3 in the not too distant future as Nikon now has a solid base to work on. CNX is not dead as some people think!
1
(1 to 100 of 178 replies)
Groups Beta