Mark Frost 10:06am, 4 May 2008
I've had this lense for about 18 months and its been great as my standard walkaround, however yesterday the autofocus seemed to pack in. I'm away from home at the moment so I guess I'll have to take it in to get it looked at when I get back but any suggestions as to quick fixes or even ideas on how much it would cost to fix if anyone has had the same problem in the past?

At 17mm it has no problems focusing and locking, however zooming at all causes the autofocus to jump to and fro, not your typical 'hunting' but jumping from infinity to 50m and back and sometimes other distances, and it doesn't lock at all. I have tried in all focus modes, with the IS on and off, in different drive modes and with different aperture & shutter combos none of which help. I've tried cleaning the contacts also to no avail. Both my other lenses (50mm f/1.8 & 70-300m IS) have no problems at all on this body, (30D) and I have no other body to test it on. Focus assist still works when manually focusing, and as I'm taking landscapes this week its no problem, but yesterday wanted the servo mode for sports and that was when the problem arose.

Any help/info greatly appreciated!!

Many thanks
estebanutz 7 years ago
Same problem here man, it works fine @ 17mm but when I zoom it starts going back and forth like like crazy without finding any focus point. Have you found any solutions yet?
Its All Shots 7 years ago
Yep me too, but I just end up manually focussing, seems to only happen when I cant get much contrast out of the subject, eg a white wall. Let us know if there's a fix too :) !!
ISO1977 7 years ago
I don't have this problem. It's weird that several people have experience the same symptoms. I would have the lenses checked out i guess.
khromo 6 years ago
Hey, has anyone of you who had the autofocus problem solved it? I'm having the same, too. The autofocus goes completely off track, it might "focus" beyond infinity, or anything. The only lens I can compare against on my 350D is the 50mm 1.4 prime, and there the autofocus has no problem at all. I've had the EF-S 17-85 now for about 3 years.
fredno 6 years ago
I had the same auto focus problem. I sent my lens in for repair. They changed a defect motor (they say). I have not received my lens back so I do not know if this solves the problem.
I guess it will arrive tomorrow, I will reply when I have the chance to test it.
fredno 6 years ago
I got my lens back today. It is working fine after changing the defect USM motor.
jworldboy 6 years ago
Anyone know the out-of-warranty cost to replace the an defected USM motor on this lens? I seem to be having the same problem as everyone else.

thanks
ista photo [deleted] 6 years ago
I have this problem too and it's well out of warranty . It's unfortunate i really like this lens for an all arounder. Would also like to know how much it is to get it fixed outside of the warranty
suemoff 6 years ago
I ran into the same problem about a week ago, at a baseball game with 2nd row seats--bad timing. AF works ok at 17mm, but is virtually useless when zoomed out any further. I'd also be interested to know if anyone has any idea what a repair like this might cost.
Gerha 6 years ago
no
dcumminsusa 6 years ago
I too just recently experienced this problem when photographing a paid event. Looks like I will be sending the lens in for repair.
mdoing 6 years ago
I also have this same problem at the 85 mm end of the range. It just goes crazy. I've had the lens for about 2 years and taken thousands of vacation photos with no problem until a month ago. It is comforting to see that I am not the only one!
suemoff 6 years ago
FYI for those of you who are having this problem, I brought mine into a local repair shop and, as someone previously mentioned, it needs the USM motor replaced. They want $190 to repair...I am debating whether to put the money into it, or buy a new lens.
Efstop Posted 6 years ago. Edited by Efstop (member) 6 years ago
Same problem with mine fitted to a 20D. Worked fine when new but will now only auto focus at 17mm. Any other lens setting causes 'hunting' irrespective of other camera settings.
Efstop 6 years ago
PROBLEM SOLVED - with my lens. Cleaned all accessible optical glass using Eclipse fluid and optical tissue. Cleaned both sides of filter glass. Tested OK. Auto focus now functions correctly at all apertures.
jcipriano 6 years ago
I just posted this response in another thread. I had this exact problem.

I had mine repaired by Canon for $135. I went through Keeble & Shuchat in Palo Alto, CA. It took about two weeks. It has something to do with the contacts that travel along the length of the barrel being worn out toward the end.

They even fixed the lens creep, but the dealer said it would start creeping again over time.
dngrov257 6 years ago
My 17-85MM recently began experiencing the same or similar problem. The lens will simply not settle on a focus point. I cleaned the contacts, but not change. I have owned it for 2 years and used it only moderately. Given the price of the lens, a significant repair after only 2 years does not speak well of Canon quality. I own several manual focus Nikkors and they only thing they have required in 20 years is a periodic cleaning.

Based on everyone experiences, it appears to repair cost is between 100 and 150 dollars, but not including the cost of packaging an shipping.
jcipriano 6 years ago
What I paid ($135), included packaging and shipping though my dealer.

And I agree, it seems pretty shoddy of Canon considering this seems to be a common issue. Hopefully the new 15-85mm will be of better quality.
stanycjw2008 [deleted] 6 years ago
@ jcipriano

Ohhhh.... when you mentioned 15-85mm, may I know when it has been release? and what is the price of it.

Thankyou
frogwasteland 6 years ago
I have the exact same problem, worked great for 2 years. Now today will only autofocus at 17mm, zoomed in the motor will just hunt until it finally locks onto the wrong focus. Quote from Canon is $95 + shipping to fix. Yes , very shoddy quality.
TheMacroGuy 6 years ago
I have the same problem. Excellent photos for approximately 2 years and then one fine day, when I am the anointed photographer for a friend's party, the lens starts acting up. Luckily I had another lens that saved the day.

Looks like 95$ + shipping.

Yeah. Sucks.
sstrongmba 6 years ago
I have the same 17-85mm lens and used it for 3.5 years on a canon rebel xt. I upgraded to a 50d and used my same 17-85 lens. I've been disappointed in the 50d's multi point auto focus when I use my 17-85. My full auto pictures are almost consistently out of focus or soft. Not tremendously, but it's noticeable, especially on group photos, even if everyone in the photo is relatively the same Depth of Field. If I switch to Program AE and pick the center AF point it focuses fairly well. The reason I switched from my Rebel XT was because I noticed my images were turning out alot less sharp. I never suspected it was my lens until now. It's been everywhere with me. The beach, the subzero temps in the CO Rockies, etc. But I've handled it delicately. Other lenses I've tried lately appear to perform better. 50mm 1.8 , 18-55mm IS. Does this sound like a lens motor , aperture hardware or glass problem or a camera body problem. Professional opinions appreciated!

Thanks!
shledge 6 years ago
Use the micromotor adjust on your 50D, see if the lens gets any sharper.
phalanx_1962 5 years ago
Same problem here in Australia, 250AUD + P&H to replace the USM. Given the amount of chat about this problem on the net, wouldn't it be nice for Canon to show some good faith and acknowledge it.
Ming Sum Raymond Shek 5 years ago
can i ask, when you zoom out to the max 85mm, even if your focussing point flashes on the subject, does it still dither back and forward? I seem to have this problem as well though only when i happen to take a photo of- for example a photo of a bare wall and it has nothing to snap or focus on other than the wall.
Gina Johnson 5 years ago
Count me in as having this same exact problem. What a PITA! Haven't sent it in to get fixed yet, but will post with the cost when/if I do.
Luis García Pimentel 5 years ago
Maybe it's because the f-number is higher at the zoom end, really the rebel autofocus is no good at more than f/5.6
HerlandGraphic 5 years ago
My 17-85mm started acting up yesterday, when zooming between 50-85mm. 17mm were fine.
I shut off the camera, waited a few minutes, shut it back on, and the error message "Err01 bad connection blah blah blah".
I "restarted" the camera (EOS 7D) once more, and the problem dissapaired.

Now I hope the lens will countinue to work, as I don't think it's worth spending half the lens' value getting it fixed...
itsallgoodamanda 5 years ago
YEAH I have had my lens for about 2 years and it seems to of packed it in ERR99 is constant on my camera and can't take pics at all in AV mode ...thought it was my camera ... but now I think it is the lens as it won't focus and is stuck in macro ... if I use manual focus I can take some pics in different programs .... so I guess it is going in for repair .. as I cant afford a new one
afterhoursproduction 5 years ago
I just took this for a real test drive after buying it used... I am happy with the images. The images Where great right off the memory card.
A little time later in Lightroom I came out with these:
[https://www.flickr.com/photos/ahpzuazua/4704917882/]
-8830 by afterhoursproduction

[https://www.flickr.com/photos/ahpzuazua/4704917930/]
Dee Lau 5 years ago
Yep same issue, funny that it's the same with everyone else. Had this for 2.5 years and recently started getting the Err01, I then cleaned the lense and camera contact with methylated spirits....the erroring stopped but I'm left with the lense sporadically hunting for focus.

It doesn't happen all the time but is annoying enough to warrant a replacement lense...perhaps a 17-55 2.8
fahad.usman 5 years ago
my 17-85 IS USM also developed this focusing issue a couple of weeks back. I bought this used lens about an year ago for about $250. I live in Pakistan and there is no official Canon lab here that can fix this issue. is there any diy fix for this?

so sending the lens to US or some other country and spend round $200 to get it repaired is not feasible for me.
ericdifate Posted 5 years ago. Edited by ericdifate (member) 5 years ago
I'm having this issue too. I've been told $110 usd and 2-6 weeks down time to fix by Canon. Hardly any use on it too. Sux.

fahad.usman -
For what its worth, I was told that it is most likely the flex cable and not the motor. I've found a few DIY tear downs by searching "EFS 17-85 Repair Manual" and it appears the cable is plug and play, no soldering. The cable is available all over ebay for +/-$10. I was thinking about picking up a couple just in case ... no clue how long Canon will support this lens. Good luck with yours.
anders emil Posted 4 years ago. Edited by anders emil (member) 4 years ago
I just bought this lens used with the exact same problem, it was a steal and i figured i'd be able to fix it myself for little money. Turns out I was right. It is indeed the flex cables that usually fail. Ebay is your friend and if you have steady fingers and an electronics screw driver set or know a friend who has the same two items, chances are you can fix your glass very easily. Clearly this is a very common issue with this lens and Canon should acknowledge that the cables they used are of such poor quality that they should offer to fix this free even if your warranty is gone. Just saying.
kalandagan 4 years ago
There is another thread about this problem with this lens, I had it too and so do a lot of owners. Must be a design problem. You guys ever notice that companies don't do product recall on defective items that don't cause death or sickness. There should be a product recall on this.
man_overboard2011 4 years ago
My 17-85 failed me when on a trip to Nepal! I had to use my 55-250 to do the job while I gave my wide angle to a repair shop. I was sceptical and they charged a lot of money. But the next day the lens seemed to work fine.

Still, it hunts a bit in low light.
ranp121 4 years ago
I bought this lens two weeks ago second hand but in perfect condition. I recently purchased a new 60D and took test shots with my other lenses and had no problem. I tested the 17-85mm from home in all lights and ranges and had no problems with quality. I was horrified when I came back last weekend from a mountain walk to find many shots where not sharp at infinity but sharp at near focus. I have never had an IS lens before, and thought maybe I should shoot landscapes without IS, but now it seems it maybe the lens then.
nivéK woods 3 years ago
I joined this group because recently I bought a used camera that comes with a copy of the 17-85mm having this very issue. I was able to fix it with a DIY method.

I spent two days reading various tear-down instructions and tearing down the USM unit completely. I eventually found that a component inside the motor unit is used for measuring the amount of rotation, and is critical for the focus motor to rotate precisely. For further details of this component, see the section "photocoupler" at this webpage by Steve Weixel:
www.photoscene.com/sw/tour/inside.htm

In the 17-85mm lens, the plastic strip seems to have etched grooves instead of reflecting strips (as was explained by the above webpage) and mine shows a deep scratch in a portion of it, right down middle. I'm guessing this scratch destroyed the grooves; without the grooves the motor was unable to tell how much it has rotated, and refused to come to a stop even if focus was achieved. The manual focusing ring is quite near to this mechanism, so the scratch, I assume, must have been caused by a grain of sand that worked its way between the sliding photocoupler and the plastic strip.

My solution was to shift the photocoupler slightly off its track, by putting narrow strips of tape as shims at the photocoupler's mount. Apparently, this minute adjustment of the photocoupler's position was enough to allow it to read the "perfect" grooves, and the AF functioned properly again.

I would venture to guess that any dirt and/or blemishes in the photocoupler or plastic strip can cause erratic focusing behaviour.

I have created a set of photos for your reference:
www.flickr.com/photos/nivek_woods/sets/72157630430286912/

I Hope this may help somebody. Success stories would be much appreciated - we will then be able to further confirm whether this is the cause of this common problem!
Sbeukers 3 years ago
I also tried NivéK woods method. i found it on another forum..

The method is not for the faint hearted. but it sure did the trick.
my optical sensor glass thingie was just dirty.

It's super fast now and spot on.
ptbambich 3 years ago
to NivéK & Sbeukers.... would you mind to post aphoto about how to shims the optpcouplers, thanks a lotssss....
nivéK woods Posted 3 years ago. Edited by nivéK woods (member) 1 year ago
@ptbambich: I didn't take any photos of the fix, and I'm kicking myself for not making a record. If you come look at the photo set I've posted, you'll see that there are 2 screws beside the sliding photocoupler. You can take the photocoupler off by removing the screws. Once you've taken it off, you can put tape on one side of the screw holes. When the photocoupler is reinstalled, the tape won't make the photocoupler unit "sit flat" - thus tilting it slightly.

You only need this fix if the grooved strip was damaged. I suspect that most lenses just need a good cleaning.
ptbambich 3 years ago
ok thanks... will try it ASAP ;-)) I'm now just a little bit frustating now....
ptbambich 3 years ago
sorry forgot to ask you... is this 2 clear plastic are touching or just floating? thanks
nemanja.cosovic 3 years ago
I have the exact same problem. I will send my lens to the repair shop.

Can anyone explain how does this happen? Why does it happen?
nivéK woods 3 years ago
@ptbambich: Sorry for the late reply! The clear plastic pieces should be TOUCHING each other. The moving (small) one is attached to a thin metal piece that acts as a spring, pushing it against the arch-shape encoder ring. If it is not touching, perhaps you can try to *carefully* bend the spring so that it sits in place, or may be you can use thinner tape :)
mitcheip 3 years ago
@nivéK woods: I have got my lens stripped down most of the way but now I'm stuck. How do you get from your image 0466 to image 0469 shown in www.flickr.com/photos/nivek_woods/sets/72157630430286912/ ? I can find lots of teardown info to replace the broken auto-focus cable but nothing that shows the breakdown of the USM assembly.
nivéK woods 3 years ago
@mitcheip: If you look at my image 0466, the USM motor unit is lying on its side. It is made up of a number of rings. Their stacking order from top to bottom is shown in the last photo of the set, 0472. Be careful which way is "up" before disassembly.

The entire stack of rings are held down by the steel ring on "top" (or on the left in photo 0466.) You can see that this ring has a "wavy" side, which is a spring that presses the entire motor together with proper pressure. This top ring is a bayonet ring, similar to a lens mount, which you must rotate counter-clockwise to take off. (Rotate about 20-30°. If you study around the ring, you will see how it is put in.) Remember to mark the installed position of this ring, it doesn’t go in all the way. (The position controls the pressure on the USM motor mechanism.) As the spring puts force to hold all the parts together, be careful not to let it to release suddenly, and damage the plastic slots that hold the ring’s tabs.
ptbambich 3 years ago
to niveK.... thanks for the advices, I already try many ways fix the problems and the result is nothing to AF, have been 3 lens with the same problems.... no success...

is the problems with focusing modul? should I buy a new one? hiks....
doublejeopardy 3 years ago
My 17-85 packed up focusing; I sent it back to Canon service centre, they fixed it for a standard charge of £52
nivéK woods 3 years ago
@ptbambich: I would imagine that any problem in the motor position sensing circuitry can cause the "focus hunting" problem as described in this thread. It may not be the encoder ring. The photodiode could be malfunctioning, or a cable could broken due to fatigue. However if all three lenses you have has the identical issue, I would start to think the camera body has a problem! Hope you can try with a different camera body.
ptbambich 3 years ago
thanks again niveK... sure I do try to different body... :)

I has ever change the AF module only, the good one for the bad.... the lens just doing perfectly... I also checked the cable... all looks perfect, the cable on the AF module is not moving.... so the problems is at the photocoupler.... but I dont got the clue for all the 3 lens

I fixed many lens... but the problem on this 17-85 and error on tamron 28-75.... a very3 frustating fix... hehehe....
nivéK woods 3 years ago
I just had to repair this same issue with my usual lens, the 17-55mm f/2.8. While this time i didn't find dirt or a scratched encoder ring, i carefully cleaned both sides of the photocoupler, i.e. the LED and the phototransistor. I also cleaned the ribbon cable connections at the main circuit board, using alcohol. I don't know which made it work, but the lens is working again. Use a good magnifier under bright light to see if you find things sticking to either parts of photocoupler.

Also try to use a multimeter to check that both sides of the photocoupler is actually functioning!
gapalmer68 3 years ago
I thought one of my 17-85 lenses had the better of me. I replaced the ribbon cable and cleared all the errors but for some reason it would still hunt at long focal lengths and then AF lock blurred.

I stripped it down to the photocoupler. In the end I realised you don't need to take the motor apart, just turn it up-side-down and undo the screws (a few of them are under the board), and once you peel back the ribbon cable it will come off. I just gave it a good clean! I have another lens that I will be doing this to so will take stage by stage photos to make it easier for anyone trying to do this!

The speed of the auto focus is now instant (like new) and even in low light it AF locks in a fraction of a second, before it would just jump around and never lock.

Thanks Nivek.
nivéK woods 3 years ago
Congratulations!!! Glad it worked out for you.
vbessphotography 2 years ago
My autofocus only works at 17mm. So I've decided to just make this my 17mm lens. Fuck it. Life's to short. I have a 24-105L but thats for my pro shoots. I use this 17-85mm lens as a walk around lens and since I'm using a 60D I always just crop what I want later...

But I understand because it does suck not being able to zoom in and autofocus.

Canon wants 150$ to fix it.. Fuck you canon you should fix the shit for free!
barrysmoore56 Posted 2 years ago. Edited by barrysmoore56 (member) 2 years ago
nivéK woods:

I can confirm this fixed my focus hunt problem. Much appreciated. The semi circular sensor was also loose at one end as well as dirty - not scratch though. I have a picture and set of other images showing the fix to a broken aperture flex cable at www.pbase.com/barry_2718/image/151503868
nivéK woods 2 years ago
barrysmoore56:
Awesome work!!
Groups Beta