Share
Roginald 5:07pm, 31 December 2017
I was going to call this thread "My Dana", but since I've just finished this project at a time when people here are thinking of their ideal writing machine, I'm going to call it "My Writing Machine" and, just for fun, describe my Dana as if it were a new device!


People who know / own a Dana may want to blank their minds of everything they know when they read this. Some of it may be genuinely new to them, also, as I've made many minor mods which all "add up" to an interesting machine.


wordprocessor




HARDWARE

========

Batteries: 3AA, NiMH or Alkaline, replaceable in the field. NiMH can give about 40 hours of typing. Carry spares if you need more time. Memory will persist for a minute or two when replacing batteries. Standby time is well over a month. If the batteries are dead after not using it for a long time, it's very quick to get up and running again by restoring the entire machine state from SD card backup - just press a button and wait a minute.


Storage: Built-in memory, plus an SD card slot for making backups.


Connectivity: USB for charging the device (if NiMH batteries are in it), and for sending text directly to a computer/tablet/phone as if the device was a USB keyboard. An external power adapter can be connected, to power the device and recharge its baterries. It has an infrared port which can communicate with some devices such as an AlphaSmart Neo.


Screen: Monochrome LCD, moderate refresh rate (much faster than e-Ink, a little faster than the Alphasmart Neo). Indiglo-style backlight. Good contrast - slightly better than e.g. the Neo even in dull conditions. A decent size, just about tolerable when editing, and excellent when writing.


Casing, Materials & Style: A fresh-looking white ABS plastic casing, making the whole unit slightly reminiscent of the old Tandy 100, but with more modern curves. The base is entirely covered with a rubberised material, with extraordinary gripping power whether on a table, your lap or nearly vertical on your raised keens when lying in bed. There are two screw-holes at the back which offer interesting possibilities for suspending vertically if required!


underside




Keyboard: A great quality rubber-dome full-size keyboard, fairly quiet, largely standard layout but with some quirks, some of which tie in to its operating system. There are four special buttons, each taking you to a built-in application.


Operating system: Instant-on - about half a second, quite a bit faster than even the Neo. Starts in the application that was active when last shut down, with e.g. the cursor in the position you were in if typing. If all you want to do is draft, you don't need to ever see anything other than the word processor application.




SOFTWARE

========

All software is keyboard-driven.


The four special app-switching buttons are organised from left-to-right in the order of anticipated workflow: Plan, Write, Log, Backup.


Some detail of the 4 apps:


1) A Planning app. A sort of cut-down Scrivener, allowing you to organise the structure of a book, using a tree-structure if you wish, and allowing you to quickly move items around. It will allow you to 'check off' each item when complete - parent branches will be automatically checked off when all children are complete.


planner




2) A Word Processing app. Can handle plain text or even basic formatting if you wish. Provides basic facilities such as word counts, search/replace, spell check and thesaurus. Has a fairly advanced bookmarking / paragraph jumping system which can help with the relatively small screen - quickly scroll through bookmarks to jump to the part you want to see. Has its own file management, allowing you to name files and see all files in a list. Automatically saves the file you were working on when you load another file. Can display in a very large font, making things easy to read, or a small font, allowing a lot more to be seen when revising / editing.


wordprocessor




3) A Progress Logging app. Rather like a spreadsheet, you will need to manually type in the hours spent writing and the word count each day. It will work out the weekly, and grand total hours & words, and the daily average. You can add your own functions / calculations if you wish, just like a spreadsheet.


logger




4) A Backup app. This will allow you to backup the entire system - all apps, preferences and documents in around 30 seconds, to the SD card. You can also use it to restore either to the same machine or another one.


backup




Further software is available to run on a PC, allowing the SD card to be plugged in to a reader, and all files to be converted to RTF.




REVIEW

======

Overall pretty good. Some extras would be nice: a backlit keyboard, an even clearer / faster-updating screen, even better battery life, and a mechanical keyboard. It would also make things easier if the planning, writing and logging software were tightly integrated.


But as it stands, not bad for a total of about £50 (including quality rechargeable batteries and custom coloured case & keys), and very suitable for the intended purpose.
Roginald 4 years ago
I think I'm about to give up trying to get thumbnails to appear in threads! I'll try to work it out, meanwhile if anyone can offer some advice!
Roginald 4 years ago
I'm afraid I'm going to give up trying to lay the text out nicely with line breaks. I don't know what the problem is, it seems I can get either no line breaks, or double line breaks rendered. You also seem to get inconsistent results depending on whether you are previewing / editing or posting.

Grrrrr....

Anyway I've got the images showing now. Whoop!
Roginald 4 years ago
Here's a picture of the back which I wanted to put under the 'connectivity' section but when I go back to edit the main post all the line breaks are lost again! There's only so many times I can re-edit the same post in the same way without throwing my computer out of the window! :

back
admin
H0OK 4 years ago
Interesting. Almost makes me want to try my Dana again. And you are right that the Dana is slightly faster turning on (and hence, if word processor was open last you jump right to your righting). This is of course because, being a Palm, you are only turning off the screen, not powering down the device like the Neo.

I'm curious about your software. Your word processor does not appear to be Alphawrite, or at least mine does not have a blank screen with just text like the Neo. What are you using? Also curious about your outliner. I have SplashNotes which I used to use on my TX. In general, I prefer doing outlines/background/research on my computer and then put it on my phone so I can always pull it out without switching screens/applications. I used to use my TX with my Dana way back when I first got it.

However, overall, you've created a great machine for yourself. Thanks for sharing your mods with us.

By the way, when you go to edit a post, it does give you screwy line breaks, but when you post the old line breaks are restored. Don't know why it does that, but I've learned to ignore the line breaks when editing a post.
muskndusk2 4 years ago
I love the font you have for the word processor. Is it available for the Neo or Neo 2?
Roginald 4 years ago
@Hookmt,

The word processor is Wordsmith. The outliner app is Bonsai by Natura, I found reference to it in this thread...

www.flickr.com/groups/39436080@N00/discuss/72157678941314...

... it was a post that seems to have been largely ignored, but it turned out to be one of the most interesting "leads" I've followed up to investigate now-obscure software. If you have a touch-screen on your Dana, even more features are available. It's a remarkable app - you could actually organise, write and export an entire book with it. The text-editing of the notes however is rather cumbersome and you can't get nice big fonts, so I went with WordSmith in the end.

It's frustrating that the software is no longer developed. A few tweaks, and it would be mind-blowing for this purpose!

Re using two separate devices for outlines and drafting, I hear you. It does actually take a couple of seconds to switch between apps and that's enough to break a flow of thought! One nice thing about all the main apps I mention is that they continue-where-they-leave-off, so the open branches and the cursor in the outliner app preserves state, which does help to some extent. Many PalmOS apps I've found do not do this.

Thanks for the tip about line breaks!
Roginald 4 years ago
@muskndusk2,

The font is Verdana, displayed in Wordsmith. It came with a Dana SD image that Vance Fry supplied. I can't find anything better than it, it's great at all 3 sizes the Dana displays, and whether bold or not. Some other fonts look okay but only in one size.

I'm not aware of it on the Neo, but there is the font-editor that unexpected human wrote for the Mac, so somebody could try making one.
admin
H0OK Posted 4 years ago. Edited by H0OK (admin) 4 years ago
Roginald:

I have a licensed copy of Bonsai desktop and Palm app, amongst my vast library of Palm apps. I now however use NoteCase Pro as it is under current development and is completely cross-platform (Windows-Linux-Android-OSX-- strangely, not iOS). It's a lovely outliner and hierarchical notes app that can take attachments and syncs across devices using Dropbox.

www.notecasepro.com/index.php
Roginald 4 years ago
@Hookmt,

I was a bit naughty with Bonsai but given it's not for sale any more I doubt anyone would object! The trial version is capped at 30 days, so I installed it on a Dana with the time set to current time, then put it on my main Dana whose clock is years behind (and I can't change it because of the lack of touchscreen), so now it's telling me I have over 4,000 days left in the trial! Very lucky really, some apps are a bit more clever at handling trial periods. Were it not for that I'd be biting your hand off for your licensed copy!

I'm about to check out NoteCase Pro now, thank you! I have an android phone and a 128GB SD card I haven't yet installed. Once done, I'll be putting Kiwix on it and possibly something like EverNote or NoteCase (hadn't heard of that before) and together the phone and Dana will be pretty much perfect, even when I go away to my "special place" on holiday with no Internet connection!
Justin_T_Call 4 years ago
Roginald, your confession about the Bonsai software somehow delights me to no end, more particularly because the software just isn't available any longer. I'd be curious to see how well it works at outlining. Right now, I'm outlining my second book, and I've been carrying a pad of yellow legal paper around with me instead of my Neo, but I really want to be typing on the Neo instead. If I could outline on a Dana using Bonsai (and REALLY outline), I'd love that.
Roginald 4 years ago
@Justin_T_Call,

While you're here, thanks for the heads up on the Plastidip! I used white Plastidip for the base of this mod. It didn't feel too grippy when I moved my finger across it, but when I used it on the fabric surfaces I want to use it on, I think it's grippier than the mesh boot-liner thing I'd been using before. And now it doesn't look quite as silly, and I have access to the battery compartment and no problems putting the stylus in! I'm really happy with that aspect of it.

Re "really" outlining, well I don't really know if Bonsai would cut the mustard for you, me not being very experienced at outlining a book. You can move entries up/down/indent/outdent, easily add/remove entries, have multi-lines of text just for the description, and add notes attached to any entry which you can get to with a key press. You can also set up keywords and tag each entry with keywords (if the Dana has a touch screen), to allow filtering etc. Also it can deal with percentages-complete rather than just a yes/no checkbox. The export feature is pretty nice, too. I don't think it can handle images for research notes for example.

I thought it was amazing for an "unexpected discovery" but probably it wouldn't seem so great otherwise, and no doubt very restricting if you've just been using e.g. Scrivener.

One tantalising feature it has is to 'link' each entry to an external app, it defaults to the ToDo app I think. I tried getting it to link to Wordsmith, in the hope that somehow, I could launch an appropriate document in Wordsmith from each item in the outline and get straight to editing the text. No such luck, it just crashes :(
Justin_T_Call 4 years ago
@Roginald,
That still seems quite impressive for an AlphaSmart compatible app. I do use Scrivener, and I enjoy it, but just as often I use an app called Workflowy, and that is even less robust than what you described. As other folks have said in other threads, sometimes you just need a machine/app/tool that does one thing well and does it simply. Scrivener has a lot of great features that make it a great companion to my writing, but I can't carry it around as part of my AlphaSmart (it lives on my phone along with all my other distractions), and I don't really need most of its features when it comes to what I really need for an outlining tool. Bonsai actually seems...well, it has all the tools I would think are critical/essential and nothing else, so perhaps it would be perfect (especially when paired with the AlphaSmart). I especially like the "percentage done" feature. That's something that I don't even have on Scrivener (that I know of).

Not being able to export outlines to Wordsmith is a shame, but no loss in the great scheme of things, I guess. In any event, if I ever persuade myself to buy a Dana, I'll have to add this to my list of wished-for mods. The biggest deterrents to getting a Dana were the shorter battery life and the questionable quality of the digital screen. I see now that most of those visual problems are relieved once the touch screen has been removed, so that's good. I see also that the battery life isn't anywhere near as good as the Neo, but it also isn't bad at all (a month's worth of life without any charging, or a few days with regular usage is about as much as my kindle e-reader). Having a built in light for writing at night is also superb. That alone might be the clincher. I was going to mod one of my two Neo devices so that it had a watch battery and some LEDs light up the screen...but I'm still not 100% convinced that's what I want to do. I have the battery light and some decent instructions from another user that modded the Neo's case for this hack, but I don't have the switch that they used, and I'm actually leaning towards modding my Neo even further so that the light can be operated with the flip of an actual switch. I don't own a soldering gun, though, and the prospect of buying one has been just enough to dissuade me from attempting the project for the time being. Buying a Dana would be much, much, easier. :)
Justin_T_Call 4 years ago
@Roginald,
Also, glad that the Plastidip worked out for you! I've been happy with my own plastidip base.
Roginald 4 years ago
@Justin_T_Call,

Yes very very happy with the base now, thanks! I have ideas for a very different colour scheme / "feel" for another Dana, and I'll be getting another can of a different colour of Plastidip. Expensive relative to a secondhand Dana, but well worth it - if you want a device for "writing anywhere", struggling to keep it still on any surface is a problem well worth solving.

Re the Dana's backlight, it's definitely a "nighttime" thing. It's pretty dim, and only becomes a real joy to use once the environment is very dark and your eyes are adapted. Great for writing in bed and not for disturbing others though.

Re Bonsai, I'd like to be clear on a few things including one I haven't mentioned yet:

* It *can* actually export to Wordsmith (it's just that it can't launch Wordsmith and let you use that as an editor for its notes). After doing a bit of an outline, I tried exporting it, and you can choose from all sorts of options. You can export to a pdb file, include notes (they get put after each heading), and even create [ ] characters to represent the completion status before each heading, and each heading is preceded by white space to indicate the nesting level. This exported file is perfectly compatible with Wordsmith, everything is done on the Dana, no need to offload to PC to convert.

* A very interesting coincidence here, for owners of both a Dana and a Neo (I see the Dana as the mothership and keep the Neo in the car so it's always nearby if I get a flash of inspiration!): Once you have an outline exported from Bonsai with [ ] characters preceding each item, it's very easy, in Wordsmith, to make this into a 'linked file' and beam it to the Neo. Then on the Neo, for a particular file slot, you get to do your typing and quickly switch to the linked file where the [ ] characters appear as checkboxes to check off on the Neo! I don't think I'll actually make use of this feature, but you know, quite a remarkable accident of technology!
admin
vrf 4 years ago
I like the white!
Roginald Posted 4 years ago. Edited by Roginald (member) 4 years ago
@Vance,

Yes I love it. I wasn't sure I would. I used vinyl dye, thanks for the idea!

After a few coats I gave up trying to mask the Dana logo. But it turns out I really like that as well. The white-on-white logo means you can ignore it if you want, but when you study it, it's like it's been manufactured that way - stylish, very clear and readable but unobtrusive.

I initially used the same dye on the 4 'special keys' but I didn't like the overall look, plus it couldn't mask the lettering underneath. Then I used a brown enamel spray paint for the buttons because it was the most 'neutral' colour I could find in small affordable cans. I didn't like that either. Eventually I splashed out a fair bit of money for a big can of grey spray paint just for those 4 buttons! I think they work well in contrast with the white of the casing and the "black" of the keyboards.

I don't think the small can of brown paint has been wasted however, I think I'll use it for the casing of another Dana, it will make it seem a bit like the kind of old bakelite used in e.g. radios. The Dana's screen can seem a little lacklustre compared to the white casing, but I think it might seem quite impressive when set into a brown retro-looking casing.
heos41 4 years ago
Roginald:
One tantalising feature it has is to 'link' each entry to an external app, it defaults to the ToDo app I think. I tried getting it to link to Wordsmith, in the hope that somehow, I could launch an appropriate document in Wordsmith from each item in the outline and get straight to editing the text. No such luck, it just crashes :(


If you are feeling adventurous - and have plenty of time and reliable & working backups ;) - you can try MegaWiki - web.archive.org/web/20030413164527/http://www.megawiki.co... - to link from Bonsai to specific WordSmith /WS/ documents. MegaWiki used to be one of my most useful and valuable applications on preOS5 Palm devices. It is the ".... ultimate linking system for Palm-compatible handhelds. ... " - web.archive.org/web/20040726084613/http://www.geocities.c... Using it is possible to have a link in the Bonsai item description or note, that links directly to specific WS document. One can find detailed description of the application compatibility here - web.archive.org/web/20030414104239/http://www.megawiki.co...

Latest version - 6.x is shareware - and probably close to impossible to register. However the latest freeware version - 5.4 - is still available from web.archive.org/web/20021223112108/http://www.palmgear.co... The syntax and initial configuration usually require learning - but after that time invested pays off :)

I did not test it on my Dana /"production device" ;) / - but if needed I can revive one of the old PalmOS gadgets still around.
Roginald 4 years ago
@heos41,

Just about to go to bed when I noticed this!

Holy heck, yes I am interested and feeling adventurous. I'll check the links tomorrow and see if I can get my head around it.

Re you reviving a PalmOS gadget to see how it's done, I'd only ask you to do that if you reckon you could work it out reasonably quickly and it would save me days. If it's likely to take you a long time, then please don't go to the trouble, I'll see if I can work it out. I may be asking you some questions after I look that the links, however!

Thank you.
heos41 4 years ago
Just a thought - using Linki /part of MegaWiki/ to jump to links requires tapping on the screen. With a non-touch screen it might need even more 'hacking', if possible .....
heos41 4 years ago
OK - initial observations after testing MegaWiki to launch WordSmith docs on Handera 330.

Presumptions:# WordSmith /WS/ is installed and registered / used for less than 50 edits. Pop-up dialogs after link activation may cause resets. Version tested: 2.2.21
# MegaWiki is installed and configured basically - e.g. it is possible to link to any of the built-in applications like DateBook / MemoPad / etc. Refer to the documentation in the zip-archive if needed.
# EasyLaunch is installed and configured - at least a stroke / button combination to activate Linki.
# X-master / hack-manager is installed and active. No other hacks active besides MegaWiki Hack & EasyLaunch.

Let's start with Linki configutration. (Please, note that I tested with version 6.0, where MegaWiki is a separate application, including Piki / Qwiki/ etc )
-> Select empty slot from 'Configure links for' (in ver5.4 - an empty slot from the 12 boxes)
-> Enter preferred symbol in 'Tags'.
-> 'Taps' - I selected '1', as double-tap usually is used to select whole word.
-> enter 'Creator ID:' WrdS
-> 'Linki:' WrdS
-> 'Type:' - select 'DB Name'. Leave 'DB prefix:' empty.

Create a WS file and save in in the internal memory of device. Let's name it AlDa . In chosen application - I used memopad, but Bonsai should work the same way - enter the name of the WS document. Select this name. Activate Linki. Select 'WrdS' in the dialog that opens. This will insert the configured symbols / 'link' around the name of the document.

Now, when you click on AlDa / NameOfTheWSdocument - it should be opened directly.

BTW - I found the unregistered version 6.0 in my archives. If someone is interested - is there a preferred place / method for upload :- ?)
Roginald Posted 4 years ago. Edited by Roginald (member) 4 years ago
@heos41,

I finally got round to playing with this stuff! Crikey this is so close to being perfect!

I wanted to try to do it without using hotsync as I have issues with that, and I think I've managed to get it VERY close to working, and with MegaWiki v5.4 so should be no problems with registration.

I have absolutely minimal experience with PalmOS, just basically the Dana, so I've been clutching at straws and there's no way I'd have been able to set it up without the worked example from you. Thank you very much for spending the time, I know these things take a lot of effort to test & write up.

I've used something called UniCMD to install X-Master and EasyLauncher and MegaWiki.

Via X-Master I've:

* Set up EasyLaunch to open Linki if I hold down the Date key for a while (but short press still opens Bonsai, very clever!)

* Set up MegaWiki slot 1 to use the ~ character to open WordSmith; other parameters set up as you suggest.

I've then:

* Tested basic use of MegaWiki by, in MemoPad, creating a link to a DateBook item (using Linki to generate the tags). Clicked on the link and it works a treat. This is magical.

* Tested desired use of MegaWiki by, in Bonsai, creating a link to a WordSmith file (using Linki to generate the tags). Clicked on the link and ... it opens the file in *AlphaWord*, and the behaviour thereafter is a bit strange (e.g. pressing an F1-F8 key in AlphaWord will return to Bonsai rather than switch to that file slot).

This is incredible stuff.

So far it looks like, to use this wonderful set up, I'll have to accept:

* Using AlphaWord rather than Wordsmith.

* Using the Dana with a touch screen.

These are not inconsiderable compromises and I'm quite torn at the moment. I'd love to leave the touch screen off and use WordSmith if at all possible.

Do you or does anyone reading this know if it's possible to entirely remove AlphaWord from the Dana, so there is no longer a conflict with WordSmith?

And do you know if there are further hacks to enable a link to be effectively 'clicked' with a keyboard?

Thank you so much for your time, I'm on the edge of my seat here, I had no idea this sort of thing was possible!
Roginald 4 years ago
@heos41,

I forgot to answer your question. It looks like I'm personally not going to need v6, but what a lot of people here seem to do is create a public folder in DropBox and provide links to it here. That's how I was able to get a hold of Vance Fry's Dana SD card image, and how I posted my batch routine for converting WordSmith files to/from rtf.
heos41 4 years ago
@ Roginald

Glad to hear it works!

Regarding the file opening in AlphaWord - if I remember correctly AlphaWord is modified / rebranded version of WordSmith. It uses the same 'creator ID' as WS - e.g. on my Dana, where I have not installed WS - an entry named 'WordSmith' with creator WrdS is available in the ROM of the device (And nothing named AlphaWord). It might be possible to remove application from ROM with something like JackSprat for example, though it is definitely 'playing with fire' And I doubt it is possible to change the creator ID of the built-in applications.

Regarding the link activation via the keyboard - while re-reading MegaWiki documentation I found info about a DA named 'Jigi' -
With this DA, you can turn off all link tapping (using 0s - don't use the Disable shortcut because this does not survive a reset), and just use Jigi to make MegaWiki jumps.
Might be worthy a try :)
heos41 4 years ago
And thanks for the suggestion for public folder in DropBox - but as I deleted my very-short-lived account years ago - probably will try something Yahoo-specific first like 'files' in Yahoo groups /if still works .../ Will test and report tomorrow :)
Roginald 4 years ago
heos41:

(I finally realised there's a 'reply' button and that's how people get tagged!)

I'm a little out of my depth, but reading between the lines, does 'And I doubt it is possible to change the creator ID of the built-in applications' mean that it *is* possible to change the creator ID of non-build-in applications? I.e. could I give WordSmith a different ID and set the id in MegaWiki to match it?
heos41 4 years ago
Yes - that will be much simpler :) Using FileZ /or similar file manager - probably UniCMD as well/ it is possible to change the creator ID of installed apps. With Filez: select a single file -> Details -> General -> change 'Creator' -> save. Some apps might 'lock' themselves, but in general it can be done.

And here is MegaWiki version
6.0
- unregistered shareware. The zip file contains X-master and EasyLaunch as well. If preferred - here is version 5.4 - freeware. Both archives are in the Files section of an old-but-remembered :) Yahoo group.
Roginald 4 years ago
heos41:

Great, I'll see what happens if/when I can change the creator ID for WordSmith when I get back to my Dana.

Thanks for the heads-up about "Jigi". I haven't tried it yet. I have already, however, confirmed that it IS possible to use this linking business without the touch screen. I noticed that Linki has a checkbox labelled something like 'jump', if I check that, then instead of wrapping the selected text in tags, it effectively clicks the link for you and AlphaWord opens the file! There's a lot of awkward key presses to make that happen so not ideal, hopefully Jigi will be better. But it's definitely doable without the touch screen!
Roginald Posted 4 years ago. Edited by Roginald (member) 4 years ago
heos41:

This is so painfully close to being a dream set up, but the closer I get the more it's punching me in the face!

I installed Filez and used it to change the ID of WordSmith from WrdS to Wrd2, then updated my MegaWiki slot 1 settings accordingly.

It worked in the sense that WordSmith is now launched instead of AlphaWord. I get the registration popups now which I guess I can get rid of by re-registering it, but there are more obstacles to overcome first. Now it keeps crashing as soon as I press any key, so I can't edit files, and have to keep resetting the Dana.

I think I've pushed my luck too far with this!

At least I've realised I don't need the touchscreen. But without it, there's a lot of key pressing to do in Bonsai to launch AlphaWord, then I'd need to set AlphaWord to full screen mode every time (it forgets, unlike WordSmith), and perhaps the most frustrating thing is how long AlphaWord takes to load up. All in all it's a long time between finding the file you want in Bonsai, and getting to see it and edit it in AlphaWord.

Probably it would be just as quick to not use MegaWiki, and instead, start each item in Bonsai with the WordSmith file name. Then to 'get to' that file in WordSmith, just copy the name to clipboard, then switch to WordSmith, exit any current doc, and paste the filename (it pastes to the file list filter text and will show just the file you want).

That's actually less key presses than currently with MegaWiki, and I think possibly quicker, because WordSmith is ready for action so much quicker than AlphaWord, plus remembers the full-screen state.

I've had a very different thought about the whole approach, which is to ditch the word processer part altogether, and just use the notes in Bonsai. You can get to the note behind an item instantly with a keyboard command. The reason I didn't like that is because you can't enter tabs in Bonsai notes, they always are scrolled back to the top by default (cursor position forgotten), and most of all, the text is too small for comfort. But now that I've installed X-master, and have realised there's a font-hack somewhere, I'm wondering if I can make the font in Bonsai notes very large? I'm about to experiment!
heos41 4 years ago
It sound like the main problem at the moment is WS :/ After 50 edits it requires registration - and does not to allow to modify / edit files further. If you are able to re-register - how it works?

As far as using notes in Bonsai compared to WordSmith - you definitely know many of the advantages of WS. Not only for formatting text, but for functionality - like bookmarking / word counter / etc. For short texts Bonsai notes might be OK - but will it be adequate for 'serious' / long writing … :- ?) Even with something like FontHack 123 /anyone tested it on Dana ? / - they are still much limited. And my main concern with them is the lack of auto-save. More than once I have lost considerable amount of text due to a crash while 'flowing' in Bonsai.

Back to MegaWiki / Jigi - it works as expected with press-and-hold button configuration. In version 6.0 you actually have to create the DA in 'configure' -> DAs & Shortcuts -> Force a link jump in MegaWiki. And after that one can activate the link if the cursor is positioned within the linked text with the selected button.
Roginald 4 years ago
heos41:

Yep, the last obstacle is now getting WordSmith into a non-crashing state! You're right, I should try re-registering it before giving up. The crash didn't *seem* to have anything to do with registration, but it would be silly not to try all the angles now I'm so close.

It could even be that prior crashes had put the system in the state it was, so starting from scratch (from my good backup before I tried any of this) is also something I need to try.

I did try the font hack in Bonsai. It worked pretty well. I set it up so that only the 'large bold' font was affected (replaced with a very large font from word to go), and set Bonsai's note font to large bold. It didn't interfere with Bonsai's main UI, but gave me a nice big font when editing its notes. It looked great. But it introduced a new problem - clearly its scrolling routine was confused by the larger font. So if you jump to the bottom or top of the note then use the up/down cursor, you need to wait for a while while it scrolls to the position it (wrongly) thinks you are in. Add to that the lack of full screen and preservation of where you were last editing, and all the other good stuff missing compared with WordSmith, and it's another tantalising glimpse of what "could have been" with just minor software changes, but alas, not to be :(

A lack of crashing is vital to me, I'll take your advice that Bonsai can crash and lose text as well! Wordsmith seemed rock solid before I started messing around with all this. I'll have one more session (well probably one or two, knowing me!) trying to get WordSmith launched nicely from Bonsai.
Roginald 4 years ago
heos41:

Can I ask about file associations in PalmOS? That might help me solving this.

In the following scenario:

I've got AlphaWord installed in ROM and WordSmith installed in RAM, and by default they both have the Creator ID of WrdS.

Then I start creating files in WordSmith and saving them.

Then I change the Createor ID of WordSmith to Wrd2.

Would you expect WordSmith to still know what files it had created? I ask this because, as well as crashing, the files it listed was a small list, not showing many of the files I had created before starting these experiments. The category was set to "All" so I don't think it was because of that.
Roginald 4 years ago
Story so far:

I reinstalled my Dana from the backup, so it was back to the fully working state I was happy with at the start of this thread! MegaWiki not installed.

I then tried doing nothing but using Filez to change the Creator ID of WordSmith, to isolate the effect that had. That was enough to cause the crashes, so nothing to do with MegaWiki. I then tried changing the version number of WordSmith to be one higher than AlphaWord (they were both v21). No effect. It takes a long long time to do these tests as I have to hard reset Dana, restore from backup, then wait about 5 minutes for Filez to scan and list all files so I can get to WordSmith! So I have a few more things to try, and it's going to be a back-burner project while watching telly etc!

I then restored again, and explored MegaWiki with Jigi, it works like a charm.

If I can't get WordSmith to launch from MegaWiki, I think I might uninstall WordSmith and use just AlphaWord instead.

After all, ONE of the big appeals of WordSmith was its file management system. But if I always launch the files from Bonsai, that's suddenly less important.

AlphaWord still gives me nice big fonts, word count, thesaurus and spell check. The one annoying thing is that I'll still have to press cmd-1 every time I enter a new file, to put it in full screen mode. But at least it HAS full screen mode. I suspect I'm being a bit of a whiner about that.

Given how amazing this set up is, on an ancient machine, not designed for this, and managing to do it even with the touch-screen removed, I think I need to reign in my expectations rather than break my back trying to get everything perfect.

But I'm still going to make a few more attempts to get WordSmith the app that MegaWiki launches. It would be SO nice. I would miss the paragraph-jumping feature that WordSmith has - that helps to overcome the small screen when navigating around and editing.
heos41 4 years ago
Roginald:
Would you expect WordSmith to still know what files it had created? I ask this because, as well as crashing, the files it listed was a small list, not showing many of the files I had created before starting these experiments.


I'd be interested to know the answer as well :) As documents created by WordSmith /and saved in its proprietary format/ have the same creator ID /WrdS/ - one can expect that the program is recognizing files with creator ID as its own. Unfortunately, I experience similar type of crashes after changing the ID of WordSmith and trying to create a new WS-formatted file. Both with version 2.2.21 and the latest 2.2.27. So, presently, I am out of ideas how to trick it to work with altered ID :/
Roginald 4 years ago
heos41:

I think I've reached my limit on this. I've tried so many things I should have prepared a matrix and ticked things off to keep track of permutations and combinations!

Some notable ones I tried:

* Install WordSmith to SD card.

* Change app name, or Creator ID, or both.

* Change version number

* Start with a factory-settings Dana, with no files created by WordSmith or AlphaWord, install WordSmith in various ways (SD card or internal, various Creator IDs and names), BEFORE trying to create any files.

I'm all out of ideas.

The one that got closest seemed to be copying the WordSmith installation to SD card. I couldn't remember the process that led up to it, but for some reason one route resulted in two WordSmith icons on the SD card. Clicking on one got the crash, clicking on the other worked (but was slow of course). I couldn't work out whether the one that worked had the different Creator ID.
Roginald 4 years ago
heos41:

One frustrating thing is that there are many threads I've found in this group which mention changing the Creator ID of WordSmith, in order to get it to co-exist with AlphaWord. While many people report differing results, very few mention crashes, so it's as if I'm missing something!

The last post in this thread is interesting:

www.flickr.com/groups/39436080@N00/discuss/72157675509858...

It mentions an app that can launch programs, and where it finds a conflict it will choose the one with the highest version number. If only MegaWiki did this. It has so many plugins that I wonder if one of them can, but frankly I feel lost in the forest now.
Roginald 4 years ago
I think this is where having more than one spare Dana is going to come in very handy.

I'm going to try the "playing with fire" option tonight. JackSprat here I come :)
Roginald 4 years ago
heos41:

I think I have to call it a day on this. JackFlashLite doesn't even run, it says the device is not supported.

I really appreciate your time, effort and input. And for putting me on to Bonsai in the first place. I'm really happy with this machine.

I think I'll get this machine back to as it was, nicely using WordSmith. Then I'll get my backup Dana set up without WordSmith, but with MegaWiki linking from Bonsai to AlphaWord. Then I'll decide which I prefer by seeing how quickly I can navigate the systems side by side, and that's the end of it.

If I do ever start fiddling again in the future and make a breakthrough, I'll post here. If you ever make a discovery, I'd be very grateful for your insight!
heos41 4 years ago
So disappointed that after /so much/ time and effort invested it still does not work as expected :/ If AlphaWorld was using different Creator ID than WordSmith. If WordSmith can save files in its proprietary format when its creator ID is changed. If MegaWiki can launch applications by name / not only by creator ID. If grandma was a guy …..

And sorry I did not verify JackSprat support for Alphasmart Dana :/ It used to be a great utility back in the Palm III series / Handera / Clie days, but it seems it can not be used with AD.

However, I am glad you found Bonsai beneficial and useful for your workflow! I agree It is a great outliner and adds a lot to the functionality of AD.

Thank you for your contribution and detaild feedback!
Roginald 4 years ago
heos41:

Yes, in some ways the fact it's "so close" makes it particularly gutting!

But I'll get over it!

There's always positive ways to look at things. The definite thing in all of this is that Bonsai is staying on the Dana, I love it and it makes it as close to my ideal planning and writing magic typewriter as one can realistically expect!

I'm very tempted to go with AlphaWord right now and use MegaWiki & Jigi to make linking between Bonsai and AlphaWord effortless. It will make the whole software setup seem wonderfully integrated, as if a "suite" of software designed for planning & writing.

It also means I'll still have access to the Dana's "send" / USB keyboard feature via AlphaWord, so it really is a versatile modern typewriter!

And I keep meaning to install Noah Pro on it. Once that's done, it might psychologically at least make up for the absence of WordSmith!

Please don't apologise for not checking JackFlash. Crikey I'd never even heard of it! I don't underestimate the time and effort it's taken you to check and write up the things you have! Thank you again.
gray447 4 years ago
It would be fun to try Noah outliner but, sadly, the inability to register it and get a password is one of those Palm facts of life. And I do use the hotsync function between my Dana and Mac, so playing the 'date' game isn't practical.
Roginald Posted 4 years ago. Edited by Roginald (member) 4 years ago
heos41:

I've just had a very minor discovery but it's made me very happy.

On the backup Dana that I'd been using to see if I'd be happy using Bonsai + MegaWiki + Jigi + Alphaword, I happened to have left WordSmith installed.

I realised the first time I "jumped" to AlphaWord, it was in full-screen mode! AlphaWord never behaves like that normally.

Then when I pressed escape, it was back to non-full-screen mode, and never returned to full screen mode thereafter for any document :(

So I opened WordSmith and went to its setting for 'remember full screen mode'. It had been magically un-checked. So I checked it again.

Jumping to AlphaWord now remembers full screen mode! Until I press escape again :( And sure enough, going back to preferences in WordSmith shows the 'remember full screen mode' has been magically un-checked again.

But I've realised I was in the habit of pressing escape because that's how I used WordSmith. When I'd finished editing a document, I pressed escape to have it jump back to the file list screen.

If I'm careful never to press escape, but instead e.g. press one of my four magic buttons to get back to Bonsai, then full screen mode is remembered permanently for every document when I jump back to AlphaWord.

Annoyingly, pressing escape at *any* time in AlphaWord breaks 'remember full screen'. E.g. if I've pressed menu, then want to escape from the menu so press escape, full screen mode disappears again! But if I can train myself to stop pressing the escape button (and in this case e.g. press menu again to close the menu) then it's okay. On the rare occasions I accidentally press it, I just need to load up WordSmith and set the preference again. So there's a reason to leave WordSmith installed.

Bizarre, but quite a nice discovery. I've also installed the Verdana font and it appears just the same in AlphaWord and WordSmith as one might expect.

So to most intents and purposes, my 'writing machine' behaves and looks just as it did before, but with a nicely integrated planner and word processor. It's a pity it takes over 5 seconds every time to open a file in AlphaWord. I think I could beat that by cutting the filename from Bonsai and pasting it into WordSmith's file filter screen.

The main time taken seems to be when AlphaWord is 'scanning files' as it says every time I jump to it. I suspect there may be a way of reducing that time, and it certainly doesn't seem necessary to scan files when you've told it which one you want to open.

It could be that it's looking for and opening files in all 8 file slots every time I jump to it. After all AlphaWord, when used normally, takes 5 seconds to first start, then switching between file slots is pretty instant.
Roginald 4 years ago
heos41:

Well fan me gently with a feather duster.

I'm in the UK and my main Danas have UK keyboards.

Two of my spares are US models with US keyboards. They have the old ROM - where the Palm OS 'apps' screen isn't full screen. I only bought them because they were going cheap, and I like the idea of spare hardware, particularly the screens, which are not all the same.

So I don't particularly mind bricking the ROM of a US one in a hair-brained experiment.

The hair brained experiment went thus:

* Get hold of the 1.5 Dana US ROM update.

* Extract the zip file to get the .prc file. Apparently that's how the update is done - you just put the .prc file on the Dana and run it.

* Download a Hex editor for the PC

* Open the .prc update file in the Hex editor. It doesn't appear to be compressed. For example you can see the text of application menu items. Lots of fun to be had there if you want to change menu item texts etc!

* Search for 'WrdS'. Over 80 instances found.

* Search and replace: 'WrdS' with 'WrdA'.

* Put the hacked .prc file on SD card

* Hard reset the US Dana.

* Put the .prc file on the Dana using UniCMD

* It installs an app called 'update'.

* Run the 'update' app.

* Wait for a while and watch the progress bar go up slowly.

* At about 80% it stopped and said the 'Big ROM image is corrupt'.

* Reset the Dana.

* It works, so not 'bricked' and maybe still functional!

* The Palm OS 'apps' screen is now widescreen, so clearly at least part of the update worked.

* All the expected apps appear to be there, including AlphaWord.

* Test AlphaWord. It appears to work fine.

* Use Filez to search for the app file named 'WordSmith' (AlphaWord) in ROM.

* Check the details of it. The creator ID is now 'WordA'. YAY!

* Reinstall all my nice setup from a backup on SD card, so Bonsai, WordSmith, my WordSmith documents etc gets loaded

* Install & set up X-Master, EasyLaunch, MegaWiki, Link, Jigi.

* Create a link to a WordSmith doc in Bonsai.

* Press the magic key combo on the link.

* Opens in *WordSmith*. It opens *quickly* and it opens it in *full screen*. No messing about. Double Yay!

* Create another link to another file. Try jumping to a file, editing, going back to Bonsai, jumping to another file etc. All seems to work & save edits fine.

* Try creating a backup of the entire setup using backup buddy onto a New SD card. I figure that if I can use all the apps I need, create WordSmith docs, and create backups, I don't care how far the ROM Update got or what other stuff might not work properly.

* Hard reset Dana.

* Perform restore from the backup

* Works a treat. All files there and editable.

Holy heck.

Now to see if I can do this with my UK Dana! Luckily I have one "spare" so I'm willing to do the same experiment. I'll need to find the UK Dana 1.5 update ROM first. If I can't I'll have to either get used to the US layout on this US Dana, or see if I can re-map keys.

I suppose I should be worried about what aspects of the ROM update didn't succeed. In spite of the progress bar only getting to 80%, the actual update may have all gone fine. Maybe the 'corrupt' message was when it was doing e.g. a checksum / hash comparison between what it had updated and what it expected, and the 'WrdA' vs 'WrdS' meant the check failed.

Anyway, it's only computers. We all know they don't really mind if the odd bits and bytes go disappearing here or there. It might sulk for a while but I'm sure it will come to terms with it eventually :)
heos41 4 years ago
Congratulations!

Impressive success - and quite a 'hack-a-bit' and methodical approach. This is amazing was to alter system files - especially when it works :)

Enjoy your 'my-way' configured Dana - you definitely deserved it.
Roginald 4 years ago
heos41:

Yes, I was pretty amazed. I think the most amazing bit was that it still booted fine after the "Big Rom Currupt" message!

Further checks reveal that AlphaWord is now updated to 1.5, so that should mean it's reliable if I ever use it.

Also, the question is now answered: It DOES seem that the CreatorID is used in some way for file associations. Now, AlphaWord does not see WordSmith files, and WordSmith does not see AlphaWord files.

I love this. It's always been too easy to accidentally e.g. open a WS file in AW, and since they support different features, I've worried about corruption. Now the only way to transfer data between them is the clipboard. Perfect.
admin
H0OK 4 years ago
Were the US models you have the old 8MB models (as opposed to 16MB)? If so, that's probably why the ROM update bailed. That update was not intended for the old models which were considered unupdateable. What Vance did for us with the older US models, is extract the three updates from withing the bigger update that would work on the old 8Mb models: Keyboard.prc, Launcher.prc and WordSmith.prc. The launcher.prc gives you wide screen and of course WordSmith is actually the update to Alphword. I still have those PRCs if you want to try them on your other US model. Let me know. I have a server I can host them on.

I suspect what happened in your case was that it did indeed update those 3 prcs and then discovered it couldn't do some of the other things it was supposed to do because it needed the 16Mb model. If so, kudos to Palm/Alphasmart for good error trapping and recovery.

By the way, you might find a utility called "Myinstall" handy. You place the MyInstall.prc in the Palm/Launcher folder and create a new folder called MyInstall in the root of the SD card. After that, any prc can be installed simply by putting it in the folder on the card and tapping MyInstall. You can even set it up to do it automatically when the card is inserted, You can download it here:

www2.hookmt.com:8080/Palm/apps/MyInstall120.zip

It's a nice bit of kit, as they say.

Fascinating what you have cobbled together here (even if you could have written a few chapters at least in the time you took experimenting :-D). Makes me so want to go distract myself with a Dana and my old Palm TX. ;-)
Roginald 4 years ago
Hookmt:

Haha! You got me! I had actually started to make inroads into my book on this Dana, which was terrifying, hence this rather extreme tangent :)

Re the US Dana I put the fudged ROM update on, it was a 16MB version. The most optimistic way I can look at what happened, is that the first 80% of the progress bar referred to updating the ROM, and the last 20% was for checking what it had done. That doesn't really ring true - I presume the checks would just be hash sum type checks which would be pretty instant. I'm just trying to reassure myself there I think!

I'm desperately hoping someone can provide me with the UK ROM update file, as I've tried the following to no avail:

* Put a UK keyboard in the US Dana. Result = enter key gives backslash, and the double-quotes are still not above the number 2 :(

* Interestingly, a UK Dana I have has a label on the ROM chip saying 'US v 1.5', so I thought what the heck, I'll risk running the US ROM update on a UK Dana. Result: It doesn't run, saying that the language is incompatible. I'm tempted to try hacking the update .prc file again, to see if I can spot a language code that I can change!

However...

Yes pretty-please, in a bite-your-hand off kind of a way, to the WordSmith.prc update file! Really *all* I want changing is the Creator ID of AlphaWord. If I can fudge your WordSmith.prc file, and it installs on a UK Dana (no language check / corruption errors), then that's the best outcome possible. Then I'll know that I shouldn't have screwed up some other part of the ROM!

Thank you.
admin
H0OK Posted 4 years ago. Edited by H0OK (admin) 4 years ago
Roginald:

Here you go, for whatever it's worth:


www2.hookmt.com:8080/Palm/dana/WordSmith.prc
Roginald 4 years ago
Hookmt:

Thank you!

I've been playing around with it for about an hour. It installs fine on my UK Dana, no issues with language region.

I'm not quite sure what's going on.

* When I leave the Creator ID as WrdS, it *appears* to overwrite AlphaWord (verified by also changing the About AlphaWord text, so I can see which version is running on the Dana). I.e. I only get one icon on the apps screen, and it launches my fudged AlphaWord. However it doesn't survive hard resets - the old one re-appears. Therefore it's not updating the ROM in the same way the 1.5 update does.

* When I set the Creator ID to WrdA, it installs fine again, and I get two 'AlphaWord' icons in the apps screen - one the original, one my updated one.

So unfortunately, there's always an AlphaWord registered with the CreatorID WrdS, which is the crux of the problem.

I have more thinking and testing to do. It feels like this is so close...
Roginald 4 years ago
Hookmt:

Well thanks again, but no dice unfortunately.

I'm not terribly hopeful that anyone will answer my call for the UK Dana ROM update file, either, so I've been trying to sell myself on the US keyboard layout.

Considering little things like AlphaWord never starting in full screen mode were annoying enough to me to drive me to try the ROM hack, I'm surprised at how well I can get my head around having to use an unfamiliar keyboard layout! It's just a different shaped Enter key and the double quote being in an unfamiliar place, really. Pity that the double-quote is a very high-use character for me, but still.

And my first ever computer when I was a little kid was the Oric Atmos, which in spite of being made in Britain, had the same thing - a rectangular 'return' key and the quotes in the place you'd expect for a US keyboard. Also, Mac users in the UK need to like it or lump it also - they need to get their heads around the US keyboard layout.

I did need a sweetener however in order to come to terms with making this US Dana my main one:

alphaword_roginald

Note the version number, the dedication and the copyright year!

As an aside, for anyone reading this in the year 2030 and wanting to do this sort of hack:

The second time round, when I tried to add the above custom text, the progress bar went up just like the first time, complete with the corruption error message. However AlphaWord was not updated at all.

This made me think it was a one-shot affair: once the ROM has been updated to v1.5, further attempts would not result in any change, and it would be impossible to safely hack the file to change the version it checks for.

Anyway I searched the .prc file in the hex editor for '1.5'. It turns out that just a few bytes from the end of the file, is the string '1.5.0'. So I changed it to '1.6.0' and this time it did the update! Hurrah!

Infinite possibilities to hack around the text in the software, and not the slightest chance of ever getting my book finished. Perfect!
Roginald 4 years ago
Hookmt:

I've downloaded the "MyInstall" utility from your link and was making very good use of it last night. Particularly useful on a Dana with no touch screen. Thank you!
admin
H0OK 4 years ago
Always happy when I get a chance to pay forward all the help and support I've gotten here over the years.
annenonymus2000 4 years ago
I have:

Dana 1.5 UK update for 16MB
Dana 1.5 US update for 16MB
Dana US update for 8MB (possibly 1.20, judging by the filename)
Dana UK update for 8MB (possibly 1.20R2, judging by the filename)

If someone PMs me I can send these. It would be nice if someone has long-term hosting so that these can be stored for posterity.
Roginald 4 years ago
annenonymus2000:

I just came *so* close to giving up on this!

I fudged the UK Dana Rom update in exactly the same way as the US one, by replacing each 'WrdS' with 'WrdA', and incrementing the version number at the end from 1.5.0 to 1.6.0.

No dice, this time it detects, before it even attempts the update, that the *updater* ROM image is corrupt.

I wondered if the UK updater was doing some kind of e.g. MD5 checksum comparison on the ROM image which the US one doesn't.

Searching the image for 'MD5' reveals there are probably plenty of bits of code in there capable of that.

However I also wondered if a simple byte addition sort of thing was being checked instead.

So I changed 'WrdS' to 'XrdR' (the first letter being one higher in ASCII and the last being one lower, so the 4 bytes add up to the same).

It worked!

I sincerely doubt it was as simple as adding byte values that solved it, maybe you just get lucky with some combinations, but frankly I don't care.

I've got me my nice UK Dana all set up how I want.

The UK Dana ROM update was the final missing link!

Thank you.
Groups Beta