Discussions (60)

Stuck shutter?

view profile

T. Mertens says:

I dropped my camera lens first onto a padded surface today. I want to say that the drop was about four feet. I didn't think much of it at the time since it didn't make a loud noise.

Hours later I tried to take a picture. I heard the shutter move and my screen went black. Then the camera turned off. I pressed the on button and I heard the shutter move again.

I took the lens off and looked to see what was going on. When I pressed the trigger, the shutter covered the sensor and stayed there. The camera turned off. When I turned it back on the shutter released.

Any ideas how to fix this?
6:11PM, 15 August 2014 PST (permalink)

view photostream

khoa_sus2 says:

The "Tough" series of shockproof cameras is only rated for drops up to 5 feet. You dropped a camera that's not designed to be dropped at all, from nearly that high, and now it's malfunctioning. Unfortunately, the only way to fix it, likely, is to send it in for repair.

Good luck!
65 months ago (permalink)

view photostream

Jeff Kontur says:

May I ask what ever came of this? I am having the very same problem only I did NOT drop my camera. I am in Cairo and was out visiting the pyramids. I took approximately 50 photos when all of a sudden, the camera just refused to take any more. I swapped out for a fresh battery even though the screen showed the battery in there was just fine. I tried two other lenses. I tried several different shooting modes and a few different menu settings. It will still shoot video just fine but will not take any still photos. The moment I press the shutter button the manual shutter curtain closes and never reopens. (Thankfully, I had a second camera so I could keep on taking pictures but now I have only one camera.)
24 months ago (permalink)

view photostream

Shoestring5 says:

Jeff I have been all over the internet for the last 20 days. My E-PL5 was tested before I set off to Morocco. All was fine and charged up. Arrived in Fez. No warmer than a goos spring here. Took the shot - odd shutter noise. Screen went black and stayed black for a second or two then turned off the power. This happens interminably. I have tried tapping it, interrupting power during the shot by opening the battery cover, resetting the pixel mapping, re-charging the battery, cleaning all the contacts, removing the battery for 24hrs etc. Camera Firmware is up to date. Updated lens firmware too. Mine too shoots video fine. The shutter just does not open after closing even with the lens off. I check the timer setting - off. What is going on. I bought Olympus ever since the XA and OM1 - OM40 through most of the Mius (?) and this is the first problem I ever had with one!
23 months ago (permalink)

view photostream

Shoestring5 says:

Just found out how to check shutter count and it is a mere R. 3,929.

As I read more the anticipated life of the shutter on the higher end of these cameras is conservatively between 50,000 and 150,000.

I am feelingless and less happy!
23 months ago (permalink)

view photostream

khoa_sus2 says:

Shoestring5:

That's really too bad. It's been a few years, but I had my shutter + sensor assembly replaced a while back, and in general, Olympus repair, at least in Canada, is super-fast and very reasonable.

That particular shutter now has 60,000+ shots on it, and is still going strong.
23 months ago (permalink)

Would you like to comment?

Sign up for a free account, or sign in (if you're already a member).