Maurice Ribble 3:40am, 30 August 2006
I'd like to use exif data in the jpg to do my geotagging. I wrote some software that update the following exif tags in my jpgs, but geotagging still isn't working. Am I missing a exif tag that flickr expects? If not is support for this planned in the future?


Maurice Ribble 12 years ago
Here is an image I updated and put into flickr. It seems to see the dummy latitude and longitude coordinates I put in, but I can't seem to use that data to get my picture placed on the flickr map.
Rev Dan Catt 12 years ago
Yup, seems that not just geo EXIF, but our EXIF module in general is having some trouble at the moment.

When someone has kicked it I'll let you know.

Maurice Ribble 12 years ago

I'm still wondering if I'm missing an EXIF tag required by flickr though. When I go to this page it says I don't have any photo's that are geotagged, but I would expect the one above would a geotagged image.

I'm hopeful this kicking will fix it, but if I'm also doing something wrong on my end I'd like to know that too.

Krypto 12 years ago
Slightly confused here - will Flickr be able to figure out the geotag info from EXIF data only, or will there need to be tags?

If the latter, are there any good tools for converting the GPS EXIF data into tags in a batch? I have a bunch ready to upload that will take ages to add by hand...

Thanks :-)
Sam Judson 12 years ago
You may be aware that if you have currently got uploaded photos containing GPS data inside the EXIF then this data is not being loaded into Flickr’s new Location database.

The following is a little web app that does just that for you.

It uses phpFlickr and I managed to write it in about 1 day.

Give it a whirl and let me know what you think.
R4vi 12 years ago
you have enabled this right?

then try import.
Sam Judson 12 years ago
that only reads the EXIF data when a photo is uploaded or replaced (unless I misunderstand), not when an Import is run.
R4vi 12 years ago
I'm not 100% sure but I think it worked for me.
Krypto Posted 12 years ago. Edited by Krypto (member) 12 years ago
R4vi - I'd managed to miss that somehow, thanks! New uploads with gps exif info are now being recognised automatically, which is just what I was after.

Sam - I tried out the script for a couple of photos I'd already uploaded. They were detected on your site ok, but the map info hasn't appeared on Flickr yet. It's only been 20mins tho - could they be in a queue?
Maurice Ribble 12 years ago
R4vi - Thank you so much! Now my images with the exif image I added automatically get added to the map view in flickr.

Krypto - If you enable exif info from that link R4vi provided you should be able to upload your images and have them automatically get placed onto the flickr map. You will have to update or reload all the images though since it doesn't seem to apply to images you already have on flickr.

Sam Judson - I didn't take the time to look at your app yet, but I'll try and take a look when I have some spare time.
Sam Judson 12 years ago
Krypto: Not sure - someone else is having the same problem. Maybe it is a cache thing (maybe we're putting the whole thing under too much load....)

Leave it half an hour and check again, and if not try my app again, and if that still doesn't work email me.

Sam Judson 12 years ago
I'm assuming you've set your global geo privacy level?

Sam Judson 12 years ago
I've just updated the script - found a bug :(

So it was my fault, not Flickr's
Krypto 12 years ago
Sam - Yep, works great now. 12 years ago
Thanks for the app sam - i'm running it now and it looks good!

Don't know why flickr doesn't have an option to import all your old exif data yet.... but anyway....
Jeremy et al 12 years ago
I had no idea it didn't find 'already' posted photo EXIF's. Thanks for this script. Any chance you can make it do more without a "next page"?
Soleil*** 12 years ago
Sam - I have tried using your app and I get the following error message every time:

Processing page 1 of 60 (1195 photos)
The Flickr API returned error code #2: Permission denied

Any idea why?

Sam Judson 12 years ago
Jeremy: Yeah I can - I hadn't realised some people might have so many photos!

*Shine*: No idea - can you try closing your browser and going back to the website, and if that doesn't work then try unauthenticating the application here:
Soleil*** 12 years ago
Sam - Thank. I have tried but to no avail. Shame as I have hundreds of exif geotagged pics already uploaded and I am not looking forward to replacing them one by one!

Hasn't anyone experienced the same thing as I have? Is there another way to do it?
Sam Judson 12 years ago
You have set the privacy here haven't you?

I'm making some more changes so it will tell me exactly which line it is failing on.
Adrian Barnes 12 years ago
Sam - I tried to get your GeoReTagr to add geo:lat and geo:lon tags to my photos which have GPS info in the EXIF, but it just tells me:
Photo "IMG_2618" skipped as location information already exists

Now I know that flickr already has it mapped because it read the EXIF when I uploaded; however I'd still like to have the tags as well. Any way of doing this?
annoyed transport [deleted] 12 years ago
Hi, I'm looking for jpegs with lat, long in the exif tags to test a photomapping application I'm developing. You can see some screenshots among my photos. Please mail me if you have photos you'd like to share..

fair statement [deleted] 12 years ago
Sam, thank you, your app worked very nicely! Very good job.
Sam, I could kiss you right now!!! I forgot to enable the read-EXIF-data preference when I uploaded over 300 pics, so you're an absolute lifesaver.

You should publish this script, it took me a couple hours to find but is oh-so-useful.
MyMapOfJapan 11 years ago
Thanks for that Sam. I used it on 3 of my images which I tagged with "Geotagger". After I uploaded them, I realised that I hadn't enabled the setting and tried your fixer page at

It wasn't obvious at first what to do, and the first time I tried I got an error. After I replaced 'geotagged' with a tag which was only in my 3 images, it went very smoothly. Here's one of the tagged images
eyesthruthelens 11 years ago
I used your program to auto map my photos to Flickr map but I got this error message : Warning: Invalid argument supplied for foreach() in /home/www/ on line 47
ice2003maiden 11 years ago
Check out this product by Red Hen Systems
The Blue2CAN

Blue2CAN is an integrated solution for GeoTagging digital still images with GPS data. Using a BlueTooth enabled GPS unit and industry leading Nikon D200, D2X, D2Xs, D2Hs, D3 and D300 product lines. Blue2CAN allows users to directly capture geospatially referenced images in the easiest, most reliable collection method today. Geo-spatial information (Lat, Lon, UTC etc.) collected from the GPS receiver is encapsulated in metadata tags of every image taken. For JPG files the geo-spatial data is contained in the industry standard EXIF tags, for RAW files the metadata is maintained by RAW image workflows and is put in EXIF tags when RAW files are converted to JPG.

Blue2CAN plugs directly into the 10 pin connector on the front of the camera without the use of cables. It uses a small amount of power from the camera to operate it's BlueTooth radio and connects automatically to any BlueTooth enabled GPS receiver in near proximity. There is "zero configuration" required, just plug it in, turn on your GPS receiver and start shooting, not buttons to push except the shutter!
lole_adole Posted 11 years ago. Edited by lole_adole (member) 10 years ago
its' working with me :) thank you very much.. good luck and best regards.
michael christofield 10 years ago
Is this website with the georetagr script no longer running or is it just temporarily down? Is there another download location or another tool that does something similar?

I'm a bit annoyed that I just uploaded a ton of pictures thinking that the EXIF data in the photo would be enough. I hadn't realized beforehand that I need to check some little preference somewhere. It doesn't make sense that you can't change the preference after the fact without having to upload everything all over again. Is it just me or are there a number of common sense issues with Flickr? For example, why can't you organize photos in the group pool like you can on your own page?

roomy knee [deleted] 10 years ago
Michael ... I totally agree with you. I've got the same issue and I don't want to go through all the reloading. The tagging method and using a decimal format ... is about as annoying and so far I've not gotten the right format to make it work.
Sam's program is giving me that same error and I've tried contacting him via Flickr mail. I'm not as verse on writing scrip to make my own web app.
Does anyone have any solutions to this issue yet? I hate the thoughts of dumping all those pictures, reloading and re-writing descriptions.
roomy knee [deleted] 10 years ago
Well I didn't find a batch method to convert and tag but I did find something easier than reloading. I went to each photo's EXIF file and converted the Long/Latt figures to decimal values (remember the negative and positive values vs N and W). Seconds/60 added to minutes ... total/60 and added to the degree figure.

I then took the set and using the "Edit" function for the set went picture to picture under the location tab and inserted the decimal values. Took time but worked just fine. Instantly each picture has the map function available for it.
ratel1 10 years ago
Ralloh.... you seem to be well ahead .

How do you get to edit the data in the exif file? I am having problems trying to edit mine. I use a Canon 40D and can see the EXIF data using DPP and CS3 Bridge but I cannot access it to add information like geo tagging. I have a new ATP Foto Finder Mini but it does not seem compatible with my camera.... any suggestions would really be appreciated.
roomy knee [deleted] 10 years ago
That's pretty simple if you have the right software. I recently had to do that when I was geo-tagging some photos and had "duh" moment with Pharos GPSr. I set the unit's time in UTC instead the actual local time ... so to correct I had to change the time in the EXIF file. You can do that with several software packages ... ADOBE ... ACDSee ... most will allow that kind of editing.

I'm not familiar with using the ATP Foto Finder but if I correctly remember a review I read on it ... it doesn't do time zones but rather the camera has to be set to it's default time zone UTC. That might be your problem.
Buckeye. Posted 10 years ago. Edited by Buckeye. (moderator) 10 years ago
Use Geosetter.
ratel1 10 years ago
Yo Ralloh, / Buckeye thanks for getting back to me. I have just got back from a photography trip in the SW of Australia hence the tardy reply.

I have no problem geo tagging pics that my wife has taken with her Canon...little Ixus 75.... and that's getting emabarrasing. The tagger I have (Photo Finder Mini) needs to be told what time zone you are in (ie UCT +8) before it starts tagging. I can read the locstat in the exif file using CS3 without a problem, But for some damn reason I cant get it to tag the pics I have taken with my 40D. The pamphlet claims that it is compatible with the 40D. I have checked all the camera settings and they seem fine.

I have had no rely to the query I sent to ATP.
roomy knee [deleted] 10 years ago
Buckeye ... I've not had a lot of luck with Geosetter. It'll tag some photos and reports errors on others. The error report doesn't even make sense. It's also annoying that it keeps wanting to center that pointer in Germany and you have to drag it back to the USA. Last straw this morning was it keeps wanting to log into another computer. Not something I like my programs doing. It gets it's maps through a PC rather than straight to Google. ANYWAY ... seems like a good idea ... not sure I feel comfortable with the problems I mentioned and a few more.
Buckeye. 10 years ago
Oh well, there y'go. I've not had any of those problems with it. Make sure you've got the latest version.
roomy knee [deleted] 10 years ago
Well latest as in two days ago. Might try it again when I get more time to work with it. Still not too crazy about programs that communicate with other computers behind my back ... so to speak.
Buckeye. 10 years ago
Hardly behind your back - it has to get it from somewhere. And the God Google itself is nothing but a big computer anyway - and, moreover, one which shamelessly tracks your browsing habits.
Thingomy 10 years ago
Having finally found a tool that interoperates with lightroom, and actually works to geotag, I have found a small problem.

The tool is Jeffrey’s “GPS-Support” Geoencoding Plugin for Lightroom

I have uploaded images that are tagged in exif, the tags are visible in the exif on the flickr site, but the tags don't get used to put the image on the map.

sample image here:

Any ideas?
Daniel Pecos 10 years ago
thingomy, I have the same issue with lightroom + Flickr export plugin

Do you use this lightroom plugin to export into Flickr? Maybe here is the problem...

I will try to export to JPG and then re-geotag to see what happens.

It's really weird!
Buckeye. 10 years ago
Have you set this:
It's disabled by default.
mammoth square [deleted] 10 years ago
I'm also confronted to this, I've put some informations and test files in this thread :
mammoth square [deleted] 10 years ago
This bug has been fixed, look at :
dkabal 10 years ago

Is the script to after-the-fact pull EXIF data into geotags still working?

Every photo is reported as:

No EXIF GPS data found for photo "IMG_XXXX".

If I look at the photo more data, it will have:

GPSVersion ID:
GPS Latitude: 38 deg 32' 41.07" N
GPS Longitude: 104 deg 38' 27.78" W
GPSAltitude Ref: Above Sea Level
GPSAltitude: 0 m

woosang 10 years ago
the script works for me...
dkabal 10 years ago
Is the GEOTAG data incorrect, then?

Laurentbas 9 years ago
Hi, I've got the same problem as Dkabal...
It keeps on saying No EXIF GPS data found for photo "Thailand".
How can I fix this?
foxgrrl 9 years ago
I have the same GPS EXIF data, and same errors. The GPS data was written with a Nikon D700.


Parse error: syntax error, unexpected '/' in /home/www/ : eval()'d code on line 1

Parse error: syntax error, unexpected '/' in /home/www/ : eval()'d code on line 1
No EXIF GPS data found for photo "whatever"
Groups Beta